Choose your top Archicad wishes!

Read more
Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

Building Material change when creating an object with Complex Profiles

Helm
Booster

Hello there!

I am having a very strange effect when creating library objects and I would like to ask if anyone has encountered the same problem and whether a solution exists.

Long story short: I am trying to create complex furniture objects. I would like these objects to properly reflect the materials they have been built with (WOOD/METAL/ETC). To do this, I have taken full advantage of the "Building Material" instance in Archicad.

This works very well when the object is built with simple walls and slabs. However, when I use a complex profile (for example as a wall), when creating the object Archicad randomly applies a single building material to the whole complex profile, even if it was created using different ones. You can see what I mean in the attached image (original construction on the right with slabs/walls/complex profile wall; on the left the resulting library object).

Yes, a solution is creating the whole structure with only simple walls and slabs, but is there perhaps a way to circumvent this problem? Is there perhaps a little hook I need to check/un-check to force Archicad to respect the originally applied building materials?

Thank you very much for any help you might provide!

 

Operating system used: Windows

 

object creating problems.jpg

10 REPLIES 10
Barry Kelly
Moderator

When you place the complex profile wall, are the surface overrides turned off?

 

BarryKelly_0-1717060952562.png

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Helm
Booster

I had to quickly check. I removed the override and resaved the object, still applies a single building material to the complex wall part. (see attached image).

 

object creating problems_02.jpg

When you are placing the object, are you using any overrides in the floor plan and section settings?

 

BarryKelly_0-1717117474974.png

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

There are no overrides in place. Not while building the object (on walls or slabs), and not on the object itself after saving. It is straight forward simple complex wall with default settings 😞

I am not 100% sure on what you are doing.

If I save a complex profile wall as an object, it looks exactly the same as it did as a wall for me.

As an object, it will no longer react with other elements though.

 

BarryKelly_0-1717137060131.png

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

I have made the same exercise on a completely new instance of archicad (to make sure the problem is not on our templates).

- created the slabs
- created the simple walls (for test proof)

- created the test complex profile wall

- saved the 3d as a library object

- placed the library object nearby

- notice the complex profile part has been changed - the different building materials have turned into a single one (the single walls I used as test proof kept their individual building material).


I have attached the PLN file in this post. Perhaps you can open it and test. Are you testing this in Archicad25? It's possible that more recent versions have corrected this bug.

Thank you for not giving up. 🙂

When you save as an object, Archicad sets the same ... set building_material buildingMatAttribute_5, DEFAULT, DEFAULT ... for each of the SPRISMS_{4} commands that make up the complex profile.

Even though each SPRISM_{4} has different surface materials (which is what you can see in 3D), the section or core building material is set the same.

That must be because it is one complex profile wall so as far as when that one wall is saved as an object it can only use one building material.

Even though it is made from separate fills and is scripted as separate SPRISMs, it is just one wall and gets only one building material.

 

The same happens with a composite wall as well.

I just tried and the same thing happens in section.

 

The taller walls are all different because they are all single skin basic walls.

 

I will try to explain more bu showing you the script.

 

BarryKelly_0-1717165351114.png

 

There is nothing you can do about it except for editing the object 3D script.

 

Barry.

 

 

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

came here just to say this.

 

I'll also add that while bMat's are part of GDL now, they really aren't doing much for the object tool. I still default to using surface overrides for saved objects, and don't bother scripting bMats into 'from scratch' objects. Maybe some day I'll regret it, if bMats are ever fully developed program wide.

for the OP, I'd suggest breaking your profiles out separately so that they are scripted as separate bMat attributes instead of lumped together as a single prism geometry.

BIM solutions and trouble shooting (self proclaimed) expert. Using Archicad 26 5002 US on Mac OS 11.5.2

Yeah, that's what I was already expecting ☹️ No easy solution. Either I have to do everything with singular walls, or turn it all into morphs. Scripting is not my forte.

Thank you so much for your help, even if it was just to confirm my suspicion that I'm doomed...

Thank you so much for your time. It helps to see I am not crazy (well, not that much 😅)

Setup info provided by author