Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

Complex profile pen override not working correctly?

__archiben
Booster
Hi all,

First post for a while - hoping someone can shed some light on this:

I override my Complex Profile timber components so that I get a thick line around the outside and the cross (continuous), or slash (blocking) through the middle are a thin pen.

This has worked since forever but I have just started noticing (only just moved formally from 19 to 21), that when the profile is placed in the model those thick and thin lines don't behave themselves . . . see attached profile and how the same profile appears placed in the reply post. Anyone else encountering this? Is there a fix?

thanks
~/b

profile.JPG
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup
4 REPLIES 4
__archiben
Booster
... and how it appears when placed ...
placed.JPG
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup
Laszlo Nagy
Community Admin
Community Admin
Hi Ben, welcome back to the forum, great to see you here again.

I checked the screenshots you posted but everything seems normal to me in terms of settings.
I also managed to reproduce this behavior, definitely looks like a bug to me.
I will report this to GRAPHISOFT.
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, Ac20-Ac27
Loving Archicad since 1995
__archiben
Booster
Thanks Laszlo,

Can't recall this happening in 20 - but I didn't use it in full-on production - so here's hoping it's a quick fix...

~/B
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup
Daniel Kovacs
Graphisoft Alumni
Graphisoft Alumni
Hello Ben,

Yeah, this is definitely a new bug. The developers are already working on the solution, we will try to fix it as soon as we can.

The bug is that in some cases ARCHICAD will not apply the different pens if the same line type is used in the profile multiple times. In this case it means, since all the lines are solid lines but with different pens, it will mess up which line uses which pen.

You can workaround the issue if you duplicate the solid line, and use 'solid line 01' + 'thin pen' for the inner lines, and use 'solid line 02' + 'thick pen' for contours.

Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!