About Archicad's design tools, element connections, modeling concepts, etc.

Stair structure not showing in section

Is there a reason why the structure of a 2 riser stair won't show up in section but if I change it to 3 it will?
AC26 | Win11 | 64 bit | 32Gb RAM | Intel i9-9900K @ 3.60GHz
Not applicable
You might have a duplicate stair at the same place.
Turns out its just a setting in flight structure settings

AC26 | Win11 | 64 bit | 32Gb RAM | Intel i9-9900K @ 3.60GHz
Scott Bulmer

Greetings, I am having a similar issue in AC25 V 4013 using Mac OS 10.15.7.  I have tried the settings noted in the solution posted above however it is not working.  Basically the stair can be selected in section but is not visible.  Please see the attached screenshots.

Screen Shot 2021-11-14 at 7.59.46 AM.png

Screen Shot 2021-11-14 at 7.59.51 AM.png

Screen Shot 2021-11-14 at 8.03.42 AM.png

Screen Shot 2021-11-14 at 8.08.21 AM.png

AC25 v. 5005 w/ MEP, Cadimage, Twinmotion 2021 using AC from AC6.0, 2.7 GHz 12-Core Intel Xeon E5 (OS X 12.2.1 Monterey), AMD FirePro D700 6GB, SSD, Artlantis 2019, Adobe CC. Used AC on both platforms.
Laszlo Nagy
Community Admin
Community Admin

In the Model View Options Dialog, go to the "Stair Options" panel and make sure the "Stair 3D and Section/Elevation" options is set to "Full".

Also, remember that your Views are using these MVO settings so you need to check and change all your MVO combinations in which you want the Stair to be shown.

Get Archicad Tips at
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, Ac20-Ac27
Loving Archicad since 1995
Barry Kelly

It seems that somehow the stair can have a different renovation filter setting compared to the components of the stair.


When they are all set back the same, all is good again.


Maybe when Yvonne was playing with the settings, it reset the renovation filters as well - if that was the same issue?



One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Geof Gainer

Similar trouble. In my case it's the 3D Docs that don't display the stairs. They show up fine in plan, section, and even when I "Open 3D Source". I even click "Refine 3D Document" but same invisible stairs. I checked out Barry's insightful suggestion, but they're all set to "All Relevant Filters". 


Any thoughts?Screen Shot 2022-07-17 at 8.00.05 PM.pngScreen Shot 2022-07-17 at 8.01.37 PM.pngScreen Shot 2022-07-17 at 8.01.55 PM.pngScreen Shot 2022-07-17 at 8.09.01 PM.png

AC fan since v 7. Currently on AC 26 Build 5003 USA FULL Apple Silicon,. 2022 Mac Studio, 32G ram. OS X 12.6.2
Geof Gainer

This occurred on a previous project in AC25. New project is in AC25, but same problem when opened in AC25. 

AC fan since v 7. Currently on AC 26 Build 5003 USA FULL Apple Silicon,. 2022 Mac Studio, 32G ram. OS X 12.6.2


Thanks everyone for sharing your thoughts! 
I remember seeing a similar case from the past. According to that it is possible that the file has a 'far from origin' issue which means that there are elements placed too far from the project origin. It's worth checking if your file is corrupted in this way or not. To do that please go to the floor plan, turn all layers on and by double clicking the mouse scroll use the 'fit in window' command. If there are elements in the distance your zoom will jump to 0.000001%. Try deleting those elements and see if it solves your issue.

If it was not related to the case, I suggest reaching out to your local support because it might need deeper investigation.


Kind regards,

Dani Benjamin
Technical Support Engineer

Geof Gainer

Thanks Benjamin, there was one odd object that was strangely far away--though not crazy far like you described. I tried deleting it anyway, but it wouldn't delete. So I just brought it in closer but still same missing stairs in 3D docs. 


By 'local support' you mean my reseller? 


AC fan since v 7. Currently on AC 26 Build 5003 USA FULL Apple Silicon,. 2022 Mac Studio, 32G ram. OS X 12.6.2

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!