BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI tool not working on Mac

Aldo de Sa
Beginner

Screenshot 2023-11-22 at 22.53.13.pngScreenshot 2023-11-22 at 22.53.43.png

 

Well, the AI Visualizer opens, and the code seems to be running fine on the terminal (at least following the user guide looks like it was supposed to be working)

Im using the Archicad 27 (Brazilian version if that matters) and a MacBook M2 Pro.

Any tips? Kinda new to archicad, been using it for a couple of months only

18 REPLIES 18

By the message at the end of the terminal windows looks like you run out of memory. Have you tried if reducing the Image Size has any effect?

Archicad 26 ARM, MacBook Pro M1 Max 64Gb, macOS Monterrey.
GAG
Advocate

@Aldo de Sa wrote:

Im using the Archicad 27 (Brazilian version if that matters) and a MacBook M2 Pro.

Any tips? 


 

Set the PYTORCH_MPS_HIGH_WATERMARK_RATIO environment variable to 0.4 or 0.6 and try again.

 

If you are unfamiliar with Terminal and environment variables, ask your more technical colleagues for help.

 

Example command in Terminal to be run in your sd.webui folder:

 

PYTORCH_MPS_HIGH_WATERMARK_RATIO=0.4 ./run.sh

or if you run runHighVram.sh:

PYTORCH_MPS_HIGH_WATERMARK_RATIO=0.4 ./runHighVram.sh

 

George
Norbert Kucsma
Graphisoft
Graphisoft

Hi Aldo de Sa,


Thanks for the question.

 

It looks like the process ran out of memory, please close all other apps running in the background and try to generate an image again.

Did you start the AI Engine in High Vram or in low Vram mode?

I suspect in HighVram, please try the add-on in low Vram.
On the AI Visulaizer UI:
- stop the engine (the button next to the 'Start AI Engine') and wait a minute

- uncheck the 'Start in High Vram mode' checkbox

- Start AI Engine (and wait for it to start)

- generate a picture

 

In case it still fails, please contact your local support and share the Terminal window output (Shell, Export text as...) as well.

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Got the following message in Terminal:

Stable diffusion model failed to load

Exception in thread Thread-2 (load_model):

Traceback (most recent call last):

  File "/opt/homebrew/Cellar/python@3.10/3.10.13_1/Frameworks/Python.framework/Versions/3.10/lib/python3.10/threading.py", line 1016, in _bootstrap_inner

    self.run()

  File "/opt/homebrew/Cellar/python@3.10/3.10.13_1/Frameworks/Python.framework/Versions/3.10/lib/python3.10/threading.py", line 953, in run

    self._target(*self._args, **self._kwargs)

  File "/Applications/GRAPHISOFT/Archicad 27/sd.webui/webui/modules/initialize.py", line 153, in load_model

    devices.first_time_calculation()

  File "/Applications/GRAPHISOFT/Archicad 27/sd.webui/webui/modules/devices.py", line 148, in first_time_calculation

    linear(x)

  File "/opt/homebrew/lib/python3.10/site-packages/torch/nn/modules/module.py", line 1501, in _call_impl

    return forward_call(*args, **kwargs)

  File "/Applications/GRAPHISOFT/Archicad 27/sd.webui/webui/extensions-builtin/Lora/networks.py", line 429, in network_Linear_forward

    return originals.Linear_forward(self, input)

  File "/opt/homebrew/lib/python3.10/site-packages/torch/nn/modules/linear.py", line 114, in forward

    return F.linear(input, self.weight, self.bias)

RuntimeError: "addmm_impl_cpu_" not implemented for 'Half'

 

I tried both settings with the same result.

Contacting the local support? I think this is a beta version and we are talking in a community,

 

Best regards,

Frank

Well, then go back to the clean start, but reduce the image size or the number of iterations in AI Visualizer add-on interface.

George

Hi Aixtreme,

 

Have you tried this?
On the AI Visulaizer UI:
- stop the engine (the button next to the 'Start AI Engine') and wait a minute

- uncheck the 'Start in High Vram mode' checkbox

- Start AI Engine (and wait for it to start)

- generate a picture

 

Please close all other apps running in the background to minimize memory usage. 

In case it still fails, please share the Terminal window output (Shell, Export text as...) as well as a picture of the AI Add-on UI. Which macOS version are you on?

 

Thanks,

Norbert Kucsma

Technical Support Engineer

Aixtreme
Booster

I will stop here with this Beta and wait for a final version, that is easier to install and working. 

AndyP
Participant

I have the same problem.

I am running AC27 on an Apple M1 Max MacBook Pro with 32GB of RAM and Sonoma 14.2.1.

The AI visualiser, refuses to run even on the lowest settings and no other applications running.

 

Screenshot 2024-01-03 at 11.17.46.png

 

Screenshot 2024-01-03 at 11.17.56.png

  

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!