Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Magic wand not working? (When modeling a mesh from a DWG imported as drawing) AC24

Mimsy
Booster
Problem is as the title. I'm trying to create a mesh from a site plan done in a .dwg file. I imported the file as a drawing (the merge function is not working) and exploded it into the current view. All the lines remained together, so I suspended autogrouping.
I then selected the mesh I'd made and tried to use the magic wand to add a ridge from one of the polylines from the .dwg drawing using the space bar, and the magic wand didn't appear. So I tried to do this manually, went into the control box palette and clicked on magic wand - and it still doesn't want to work. My cursor shows the magic wand, but just behaves like an ordinary mouse click.
Just in case it was a problem with the .dwg, I drew a line using the line tool, and again selected the mesh and tried to use the magic wand to create a ridge. Still didn't work.

Does anyone know what is going on?
AC24 Australia | Windows 10 64 bit | IC3D Workstation, 64GB RAM, 4.9GHz i9 core
5 REPLIES 5

Barry Kelly
Moderator
Do you have the mesh tool active, then select the mesh and then magic wand?
The mesh tool must be active.

Also if they are individual lines, they must join end to end, they must be grouped and the grouping must be enabled.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Mimsy
Booster
Yes, the mesh tool is active. It could be that when I exploded into current view, ArchiCAD broke everything into individual components. That could be the problem, but I'm not sure how to stop it from doing that.
AC24 Australia | Windows 10 64 bit | IC3D Workstation, 64GB RAM, 4.9GHz i9 core

Barry Kelly
Moderator
Mimsy wrote:
It could be that when I exploded into current view, ArchiCAD broke everything into individual components. That could be the problem, but I'm not sure how to stop it from doing that.

The DWG may have been drawn that way.
I don't even think there is an option in the DWG translator to change that.

However, once exploded, you can select it all and use the 'EDIT > Reshape > Unify' command to join all of the single lines that join at the ends int a single polyline.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Podolsky
Newcomer
Lets be honest here: if you are placing DWG as a drawing and after explode - you are getting lines. What means 'individual components' - I cannot imagine. If you open DWG file as a file - you still getting lines or polylines.
There is no difference if you have lines in group, non-grouped or united into polyline - magic wand still trace them all absolutely similar way.
Do you mean that all your topographic contours from DWG converted into library parts? I don't know how then that happened, but you can explode them and get lines on plan.
To check what's wrong maybe try first to trace your lines with lines - just choose different colour, to see is magic wand working. If magic wand just stopped working in any case - then it is program bug. Try to restart ArchiCAD.
In tracing lines as ridges of mesh there is no secrets - it must work straight forward. The only steps you need to perform - select a mesh, select mesh tool, click on line you want to trace holding space bar.

Mimsy
Booster
Yep - it was a software glitch. I closed down that project, opened a different one, tried something similar and it worked, so I opened the original project and it worked. The old 'have you tried turning it off and on again'
AC24 Australia | Windows 10 64 bit | IC3D Workstation, 64GB RAM, 4.9GHz i9 core

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!