cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Elevations: Show colours through transparent surface?

Anonymous
Not applicable
Hi all.

I have an elevation with a glass window, transparency switched on, can see through all ok. However nothing comes through in colour - its all hidden line?

When I remove the glass, or any surface that is transparent, colour is visible. Example attached.
The material is switched to full transparency, the vectorial hatching set to Empty Fill, and the elevation settings have cut surfaces in colour, transparency on etc.

Appreciate any help!
Thanks

JG
17 REPLIES 17

runxel
Ace
Yeah, that is not great.

There is a workaround: You have to set the glass material to be fully transparent. A full 100%.

One caveat tho: in 3D ... well, it will be kind of invisible now. However, if you set a vectorial fill for the material with a fixed pen, it will give you really neat looking sections/elevations, where the colors are blending just like you would expect.

Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Podolsky
Ace
You also can try this trick - if you expect to have perfect graphical representation. After you set glass to invisible and set to show vectoral fills for it, you can draw on top additional semi-transparent fill or use gradient fill, that goes from colour into transparency. See attached example.

Anonymous
Not applicable
Thanks for this - its already set to 100% and want 2D elevation so I can control view depth (marked distant area)

Surely Archicad allows for colour transparency?

JG

Anonymous
Not applicable
Yeah I just want glass or any 100% transparency to show objects that are located behind in colour. Doesnt seem to work in any method I use besides simply creating a blank hole in the wall - then I loose window frames and can't use window objects, glass door objects etc. But if I could get this to work, the fill over the top as you suggest is a good idea.

JG

Eduardo Rolon
Moderator
Try using a GO to change the material of the window (including frames) to Airspace.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08
Puerto Rico, BVI, Miami

Vectorworks 2023

runxel
Ace
grejxx wrote:
Yeah I just want glass or any 100% transparency to show objects that are located behind in colour. Doesnt seem to work in any method.
Did you tried what I wrote? It's definitely working. 🙂
Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Anonymous
Not applicable
Did you try what I wrote? It's definitely working.

Yes, see my settings. All the same - still grey / hidden line?
I can use any glass/material with wall/slab/object and it is all the same.

James B
Graphisoft
Graphisoft
grejxx wrote:
Yes, see my settings. All the same - still grey / hidden line?
I can use any glass / material with wall / slab / object and its all the same
It's because your 25% vectorial hatch is obscuring anything behind it. Should change to a background or airspace fill.
James Badcock
GRAPHISOFT Product Manager

Anonymous
Not applicable
James wrote:
grejxx wrote:
Yes, see my settings. All the same - still grey / hidden line?
I can use any glass / material with wall / slab / object and its all the same
It's because your 25% vectorial hatch is obscuring anything behind it. Should change to a background or airspace fill.
Thanks, i've tried airspace, background, empty fill etc...eg attached

runxel
Ace
But have a look James, it does work even when there is a vectorial fill being set.
As you can see it creates a nice transparency effect and it will blend the colors of the fill set in the surface material with the yellow wall behind.
Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Podolsky
Ace
What I see here - one person on Windows and another on MacOS. Same settings for glass surface, different result. Maybe also different versions of ArchiCAD?

Podolsky
Ace
OK. I know where the misery is hidden. What Runxel explains only works when thickness of glass panel set to zero and transparency is set to 100. In all other cases colour is disappearing.
Tested on ArchiCAD 24, Windows 11.

Anonymous
Not applicable
It's because your 25% vectorial hatch is obscuring anything behind it. Should change to a background or airspace fill.

When I start a completely new file from scratch, and import this in with the same elevation markers and surfaces, it finally works? I'm using the same material and elevation settings - just a new file. I've tried exporting the environmental profile back into the existing file, however does nothing. I"m keen to not start from scratch and would love to know what obscure display setting is causing this

Podolsky
Ace
Are you able achieve colouring if your glass panel thickness is bigger then zero? How I understand this - ArchiCAD engine does not show colours through transparent objects. Only if ArchiCAD understands transparent surface as non-existing - that is achievable by both setting glass panel thickness to zero and transparency to 100% - then you can see colours, because ArchiCAD shows only contour and vectoral fill of glass panel, when 3D surface of it doesn't exist anymore and skipped from calculations.

runxel
Ace
Podolsky wrote:
Are you able achieve colouring if your glass panel thickness is bigger then zero?
Yes. In my screenshot the glass is actually a thin wall with a few centimeters in thickness!
Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Podolsky
Ace
Then you have a magical ArchiCAD. I cannot reproduce in my computer.

Anonymous
Not applicable
Thanks for all of your comments, I appreciate the help.
After trying absolutely EVERYTHING, i stumbled on a post about Legacy Mode....finally this is fixed.
The files date back many years (Archicad 14 or so) and this gets selected I think be default.

Cheers

JG

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!