BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.
SOLVED!

AC27 IntelMacs: 3D view causes the freezing of all views

Romans
Expert

This misbehavior started with the AC27 Technical Preview and is still happening in the now available final release:

Opening the 3D view or selecting something in the 3D view, or changing something in the 3D view almost always leads to the freeze of all open views. Sooner than later. No more interaction within the views is possible.

Saving and also BIMcloud operations (Send and receive, release all, etc.) are still possible.

But only a restart of Archicad resolves that issue.

It is a problem mainly (only?) happening on Intel-based Macs.

And yes, 3D Antialiasing (with Hardware antialiasing mode) and the new Physically based renderer in 3D Window (Work Environment settings) are turned off.

Also, miscellaneous MacOS systems make no difference.

Any news /workarounds about this critical problem?

A 3D application without the option to work in the 3D view is rather weird.

Apple iMac Pro with macOS Sonoma, AC 5.0 to 27 INT and GER, all the latest
3 ACCEPTED SOLUTIONS

Accepted Solutions
Solution
Greg Kmethy
Graphisoft
Graphisoft

Dear all,

 

Let me recap what has happened so far and what are we doing to address this issue:

 

The issue was first detected during the Archicad 27 Technology Preview. Our tests showed that it occurs inconsistently on some Intel-based Macs with specific hardware specs and is video card-related. Our tests suggested that turning antialiasing off is a workaround for the problem. Therefore, we released Archicad 27 in September with antialiasing turned off by default and with a built-in mechanism to report if this problem still occurs.

 

Soon after the official release it became clear that the problem is still happening at multiple sites. We involved Apple in the investigation as the problem seemed limited to certain hardware. It still seemed antialiasing-related, so we released Archicad 27.1.0 with a safety protocol included that force-disables this feature (regardless of work environment settings) if a computer failed. We saw that the safety protocol mitigates the issue, but does not solve it completely.

 

Meanwhile, our research with the help of Apple developers found a possible permanent fix that works regardless of the antialiasing setting. We needed external validation for this fix. This is quite unusual, but since in our internal tests turning off antialiasing was enough, we needed to see the fix in effect on customer's computers that still had the problem. The validation concluded successfully - all external validators confirmed that it works. Unfortunately, this was not in time for the release of 27.1.1.

 

We are now integrating this validated fix in our Archicad code base in all language versions. The next update (planned for February) will contain this fix, but  we will start distributing the fix to affected users sooner than that.

 

We apologize for everyone who is affected by this issue and thank those who assisted us validating the fix!

Gergely Kmethy
VP, Customer Success, Graphisoft

View solution in original post

Solution

Dear Maximilian,

The Release Testing and Validation Department is working hard on making this update tested and available for the most affected language versions during the next two weeks. Please keep the automatic Check for Updates function enabled in Archicad, and subscribe for the Community Insights to get notified asap.

Best regards,

Tamás Gáspár

View solution in original post

Solution
Tamas Gaspar
Graphisoft
Graphisoft

Dear All,

I am happy to announce that Archicad 27.1.2 has been released for INT, USA, UKI, NZE, AUS, GER and AUT language versions. Further languages are coming next week. - Check the Graphisoft Downloads page for the installers.

Thank you again for the patience!

Tamás Gáspár

View solution in original post

38 REPLIES 38

So glad they took four extra months to release 27 so that all the bugs could be worked out. Sheesh!

 

Thanks for reporting this! This means I can't use my office computer but will always have to lug my laptop from my home office to my downtown office just to work in 27. I'll of course have to confirm it, but with the other buggy stuff I've seen, I can believe it.

Rex Maximilian, Honolulu, USA - www.rexmaximilian.com
ArchiCAD 27 (user since 3.4, 1991)
16" MacBook Pro; M1 Max (2021), 32GB RAM, 1 TB SSD, 32-Core GPU
Apple Vision Pro w/ BIMx
Creator of the Maximilian ArchiCAD Template System
fabioferrini
Enthusiast

Some issues in our office, 3 iMac 27intel based AMD 5k 😞

Chuso
Contributor

Hi Romans,

 

I am having exactly the same problem. 

A fresh project started on AC27 with an iMac 27 intel and at some point when opening the 3D window all archicad windows freeze. 

I tried installing AC solo, and same problem. Even upgraded to Sonoma despite the known issues, but still happening. 

 

I hope it gets sorted in the next update...

I strongly recommend addressing this problem with your local support/distributor to generate the necessary relevance and priority.
As you can see, here in the forum there is no communication from GS about this. Rather disappointing. 

Apple iMac Pro with macOS Sonoma, AC 5.0 to 27 INT and GER, all the latest
Oleksandra Vakariuk
Graphisoft
Graphisoft

Hi everyone,

 

This is a known issue, DEF-14953, Archicad's windows become unresponsive (and might turn red or grey) on some macOS machines. As to our knowledge, those with AMD and a few Intel graphics cards are affected. It has been our top priority ever since we discovered it, and our developers are actively and continuously working on it.
The problem appears to be triggered by 3D Antialiasing. However, disabling it may work only temporarily or not work at all due to another issue where Work Environment enables 3D Antialiasing even though it's disabled in the settings.

We have been in contact with Apple’s developer support regarding these issues, and we have a fix under way. As for now, we've made a decision to disable 3D Antialiasing on all affected machines. This temporary solution will be included in Archicad 27 Update 1, and we'll revert it as soon as the final fix is ready.
We sincerely apologize for the inconvenience caused by these issues.

 

Kind regards,

Oleksandra Vakariuk

Technical Support Engineer

Hi Oleksandra,

 

Thanks for your replay,

Unfortunately, we have noticed that disabling 3D antialiasing works when working with new files created in AC 27. However, this does not work with some older files created in AC 26 that are opened and saved in AC 27. For example, we have a file converted from AC 26 to AC 27 that creates the same 3D crack issues. The same file, on the other hand, crashes when attempting to upload it to BIMcloud as a service, right at the end of the download process. Work perfect in AC 26. I have sent this particular file to my local Italian distributor. Nonetheless, I can provide a link for you to download it and run some tests if you send me a private message. Thank you. Fabio

 

Dear Oleksandra, 

Thank you for updating the community about this critical issue. 👍
On the other hand, it is clear that not only "some" macOS machines are affected, but almost all Intel-based Macs (with AMD GPUs) and all macOS.

Disabling the 3D Antialiasing is not a real 'workaround' as we already know.
Also is it disheartening that the so badly needed fix will not be included in the upcoming update 1.
A 3D application without the ability to use the 3D window is just hard to use.

Kind Regards
Roman

Apple iMac Pro with macOS Sonoma, AC 5.0 to 27 INT and GER, all the latest
Oleksandra Vakariuk
Graphisoft
Graphisoft

Hi Fabio,

 

Unfortunately, I cannot offer any workaround regarding the issue you're experiencing with migrated projects. I can only recommend to continue using Archicad 26 until Archicad 27 Update 1 is released.

Regarding your other issue, I have received the file from our colleagues and I could reproduce the crash. On Tuesday, I sent the file to our developers for further investigation. I'll let you know as soon as I hear from them.

 

Kind regards,

Oleksandra Vakariuk

Technical Support Engineer

As far as I can tell, there is no solution at hand. Graphisoft has known about this issue since July and still hasn't found a fix for it. And I wouldn't count on one.  What gets me is that Graphisoft knew about this issue and said nothing to us about it, No Warnings, no nothing.  Let us Download, install, and burn.  

 

I also believe that part of the blame rests with Apple as well. They no longer fully support the Intel chips (or half-heartedly) and are focused on the silicon chip Macs. Thus, there is clearly a glitch in the conversion from silicon macOS to macOS software for Intel machines, one which most likely will be ignored or not fixable. The 2019 iMac is the last iMac that Apple is going to support after that...... Nothing. The only real solution to this issue is a new silicon chip machine, which I have no interested in purchasing right now.  

Learn and get certified!