cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Installation & update
About program installation and update, hardware, operating systems, setup, etc.
SOLVED!

ARCHICAD 27 - Slow zoom and pan

HK ARCHITECTURE
Contributor

Hi,

 

I recently been using Archicad 27 and i clearly notice that this version is very slow when i pan and zoom (in or out) in 2D. It seems to get worse the more time i spend working and the more object the project has displayed. This does not happen in 3D. The zoom is slower when the mouse is over an object or wall or something...I worked before on Archicad 25 and never had this issue. The PC specs are good : I9 13900KF, RTX 3090, 64GB RAM, SSD disks...

Can someone give me some advice to what's seems to be happening here ?

 

Thanks !

HK ARCHITECTURE - Kévin PAIVA (France / Portugal)
Archicad 27
Windows 11 / I9 13900KF / RTX 3090 / 64GB RAM DDR4 / UltraWide Monitor
2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution
MASz
Enthusiast

Have you tried using the old drawing infrastructure? 

 

Open Registry Editor and navigate to Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\Archicad\Archicad 27.0.0\Graphix
Change RenderingAPI value data from 0 to -1

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display

View solution in original post

Solution
MASz
Enthusiast

The new 2d drawing infrastructure was introduced in Archicad 26. You can read about it here. It may be faster in some cases, but much slower in others. I tried to get answers from Graphisoft on this and to try and encouraged them to have a more reliable solution. Nobody could tell me anything about the performance and this didn't go anywhere.


I also tried to tell Graphisoft that this is problematic and they should have a setting in the Work Environment at least since it's really not going to be obvious to a lot of users. The display scaling is also bugged on the new drawing infrastructure and there's really no indication they will fix this. Other than forum posts, none of this is properly documented and it also means that technical support don't have the tools necessary either without deeper knowledge of the program. In general, there's complete disregard of whether the full releases are going to be usable for people or not. 

 

In 3d, DrawShadowsDuringNavigationOGL is also bugged and affects performance, even without shadows enabled. Open Registry Editor and navigate to Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\Archicad\Archicad 27.0.0\GSModeler and change DrawShadowsDuringNavigationOGL to 0.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display

View solution in original post

21 REPLIES 21
Barry Kelly
Moderator

Do you have Trace & Reference turned on?

If so try turning it off.

 

Also check your Advanced Redraw Options in the Work Environment.

 

BarryKelly_0-1715304170803.png

 

And this may sound strange, but if you have any floating palettes, try turning them off or docking them.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Is this floating issue still a problem??

I am using two monitors. One is the working/design window of Archicad without any palletes docked.

The other monitor has all the palletes (Navigator-organizer-Toolbox etc.....)

Apart from the DirectX problems in comparison to the OpenGL (flashing windows) I am not noticing any lagging.

The mouse polling rate is causing problems if it is above 500hz. 

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.

@Botonis wrote:

Is this floating issue still a problem??


I don't know, but I have read it has caused problems for some others in the past, so I thought I would mention it.

I can't say i have noticed any problems except when my RAM runs low.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
HK ARCHITECTURE
Contributor

Hi,

 

Thanks for the replies. But i've tested all those things and the problem persists.

 

Trace & reference : Trace & reference disabled

Work environnement : I have disabled 2D and 3D antialiasing options.

Palettes : There are no floating palettes on my workspace.

Mouse : My mouse is a Logitech Master 3, so the polling rate is under 500hz (125hz).

Test : I tried Archicad 27 on a laptop and the issue is the same, so i believe the issue comes from Archicad 27 and its not a hardware factor... (laptop specs fyi : I7-9750H, 16gb RAM, RTX 2080, SSD disk).

 

I recorded a short video demonstration to what's happening : I opened the same .pln file on both Archicad 25 (left) and Archicad 27 (right). You can see my work environnement options and then i show the lag I'm experiencing on Archicad 27 that does not exist in comparaison to Archicad 25 (i have also tried this with other files and new files, and the result is the same). Also, from now and then, when navigating on 3D on Archicad 27 the software crashes suddenly (nvlddmkm error from the Windodws event log).

 

I hope someone can help me with this issue. My company is still using Archicad 25 due to this problem...

 

Thanks in advance,

HK ARCHITECTURE

 

HK ARCHITECTURE - Kévin PAIVA (France / Portugal)
Archicad 27
Windows 11 / I9 13900KF / RTX 3090 / 64GB RAM DDR4 / UltraWide Monitor
Solution
MASz
Enthusiast

Have you tried using the old drawing infrastructure? 

 

Open Registry Editor and navigate to Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\Archicad\Archicad 27.0.0\Graphix
Change RenderingAPI value data from 0 to -1

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display

Hi MASz,

 

I changed the Rendering API and It worked ! I dont have the cluess idea to how this works or what i just did, but now, all I know is that it all runs very smoothly and fine on Archicad 27 !

 

Thank you very much for your help !! I've spent hours trying to solve this problem i would not have found the solution withour your answer !

 

HK ARCHITECTURE - Kévin PAIVA (France / Portugal)
Archicad 27
Windows 11 / I9 13900KF / RTX 3090 / 64GB RAM DDR4 / UltraWide Monitor
Botonis
Advisor

It seems that I am already used to this bad performance that started with the release of 26 and the change of the OpenGL to DirectX.

There has been so many discussion about it that at the end I got bored and never changed the registry.

@HK ARCHITECTURE can you check the graphics quality after the change? Antializing performance, text, lines etc whether it is better with the previous rendering API?

 

Thanks. 

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.

Hi,

 

I just made a video showing Archicad 25 (left) vs Archicad 27 (right) after set the RenderingAPI to -1. As you can see, all works the same as Archicad 25, which is great !

- 2D navigation : Works perfectly now

- 3D navigation : Does not crash anymore

- Antializing : I don't like to use it for 2D but it works pretty well, just a little bit slower on both versions..

- Text : Works well, I don't see any difference on inputs and display

- Lines : Works well, same, I don't see any difference between before and now

- Object : Same

 

Hope this can help !

HK ARCHITECTURE - Kévin PAIVA (France / Portugal)
Archicad 27
Windows 11 / I9 13900KF / RTX 3090 / 64GB RAM DDR4 / UltraWide Monitor
Solution
MASz
Enthusiast

The new 2d drawing infrastructure was introduced in Archicad 26. You can read about it here. It may be faster in some cases, but much slower in others. I tried to get answers from Graphisoft on this and to try and encouraged them to have a more reliable solution. Nobody could tell me anything about the performance and this didn't go anywhere.


I also tried to tell Graphisoft that this is problematic and they should have a setting in the Work Environment at least since it's really not going to be obvious to a lot of users. The display scaling is also bugged on the new drawing infrastructure and there's really no indication they will fix this. Other than forum posts, none of this is properly documented and it also means that technical support don't have the tools necessary either without deeper knowledge of the program. In general, there's complete disregard of whether the full releases are going to be usable for people or not. 

 

In 3d, DrawShadowsDuringNavigationOGL is also bugged and affects performance, even without shadows enabled. Open Registry Editor and navigate to Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\Archicad\Archicad 27.0.0\GSModeler and change DrawShadowsDuringNavigationOGL to 0.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display