Installation & update
About program installation and update, hardware, operating systems, setup, etc.

ArchiCAD demo freezes at splash screen

Not applicable
Alienware M17x laptop
Windows 7 64-bit Ultimate
Dual-core 2.93GHz system
8GB of RAM
two Nvidia 240M graphics cards each with 1GB of memory

The program has never worked for me. I double-click the icon, I see the small splash screen, then the program window appears behind it, and then it just sits there.

I've looked at the compatibility modes, but my only options are a few versions of Vista (I guess because of the 64-bit version). I've also tried running the app as Administrator.

If I click on the splash screen, Windows tells me that the program isn't responsive and gives me the option to kill it or wait. I've let it sit for hours, but the hard drive isn't doing anything, the program is just stalled out.

I'd appreciate any advice. I've already lost two days of my demo period just trying to get the program started.

quick edit: my drivers are up to date with the latest stable release, direct from Nvidia, I've tried rebooting in between. I'll try a reinstall when I get home tonight, but if I can't get it running after that, I'll have to give up on the app and look elsewhere.

Not applicable
Update: I reinstalled my video drivers, and ArchiCAD was also reinstalled, my system was rebooted, and the application still freezes. The splash screen loads, the app window opens behind it, and then nothing.

Not applicable
I'm also having the same issue with ArchiCAD 14 on Windows 7 (albeit 32-bit)...

I'd really appreciate any help

Not applicable
I got similar problem. It freezes. I have 13 and 14 on the same computer. Both used to work. Then suddenly none works now. I tried repair and did not wprk. Then did uninstall both and then reinstalled both. But problem remains.

Mine is stand alone version( not demo one).
I event tried to run in demo mode but no luck.

Graphisoft Alumni
Graphisoft Alumni
This could be an issue with the WIBU or CM drivers you have installed. Something quick to try would be to take your WIBU/CodeMeter key out of your computer. Then uninstall and reinstall the drivers and then restart your computer.
Tim Morse
Support Engineer
Graphisoft North America

Not applicable
Thnaks for the suggestion.

Removed the key. Uninstalled the wibu driver. Restarted the computer. Reinstalled the driver.
Restarted the computer with key . Archicad still freezes at flash screen.

Restarted the computer without key and tried to run in demo mode. Still it freezes at flash screen.

Not applicable
Finally figured out the solution.
The quick time was corrupted. I tried to run it and will give me error messsge. I did uninstall and reinstall of quick time. Then ran it to see it works.

Not applicable
Hi niriyo
Totally irrelevant to AC.
I was just telling someone about a story of skydiving in small airport in Simi
Valley the other day(a miraculous free fall recover). We lived in North Hollywood at the time.
When I was around 14-15 I think, mid 60's or so, my dad was a pilot who took skydivers up in a Cessna 180 and they would land in large open field next to the little one hanger airport there in Simi Valley.
I use to drive the truck to pick them up as it was on private property.
Anyway don't think the airport would be there now, most likely large subdivision I would assume.
Anyway, welcome to the forum.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!