BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Archicad crashes when switching to Vectorial Engine from OpenGL

Not applicable

I am testing the Surface Book 2 with the dedicated GTX 1060 to see how it can handle 3D Software like Archicad.
Even though it runs ok on when using the OpenGL engine, the model freezes when I try to use the Vectorial Engine.

At the beginning I thought that the graphics card just couldn't handle the model I was using, but then I tried a new project with just a wall element and I had the same problem. I know the surface book should be able to handle it because I could do this with my 9 year old MacBook Pro.

I can see that the GTX 1060 is in use when I am rotating the model in OpenGL so I guess it's not an issue of Archicad not utilizing the dedicated graphics card. (there were some known issues with archicad and laptops with dual graphic cards -

Has anybody experienced something similar or know what can I try?

I only have a few days to decide on the laptop and I do like it a lot but wouldn't keep it if this an issue that can't be resolved easy.

I have already:
-set power mode to best performace
-used the nvidia control panel to change the global settings to high performance nvidia processor, and also for the specific program
-used the laptop while charging
-made sure the driver is updated through the device manager
-updated and installed all windows updates
-run the Surface Diagnostic Toolkit
-tried 2 different versions of Archicad (same exact problem on both versions on an existing and a new file)

Thanks for any advice!
Karl Ottenstein
The vectorial engine doesn't use acceleration - it is ancient. So, the crash is surprising. Which versions of AC did you try (release/build and professional/student/etc)?

It looks like the Surface comes with the latest Windows 10 Pro update... 1909... which had some problems reported here:

I wonder if changing your Locale would resolve the issue, as it did for the posters in that thread?

Did you go into your Work Environment (before switching to Vectorial) - to the User Preference Schemes > Advanced Redraw Options and try disabling all options there - and turning acceleration to off? If that resolves it, try adding those things back gradually to track down the issue.

Hopefully either those settings, or changing our Locale, will resolve this for you.
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.6, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Not applicable
Hello Karl,

Thanks for your time and suggestions.
Changing the locale settings unfortunately did not work for me. The box wasn't ticked on my laptop.
I have also tried what you suggested and even though there was more loading time, again it didn't work and the 3D window crashed.

I contacted Microsoft support who told me to do a fresh start, but this didn't resolve it either.
It seems that I will return the unit, I am not sure if I should order another one or get a new laptop all together as I am not sure if this is an issue with the Surface Book or Windows 10.
Not applicable
Oh I have used and Archicad 23 in Demo Mode and Trial mode and Archicad 22 (professional).
Learn and get certified!