Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Keyboard shortcuts not working in new surface laptop pro 7 windows 10 home

Not applicable
Hello everyone!
Since we are on quarantine I finally have the time to search for a solution for this problem I have since I bought my new laptop. I am in Greece and I had English windows pro 7 for the past years. I am using ArchiCad 22.
Now I bought the new surface pro 7 which had windows 10 and all my shortcuts dont work. I cannot use ctrl + D to move, or shift + R to set a distance. It is frustrating!
Anyone had the same problem ??
Hi Wendy,

First check, which Language Windows 10 shows in the Taskbar (bottom right in most cases). For me ist DEU (german).

But sometimes Users hit a Windows 10 specific Shortcut that instantly changes the input Language (and the Keyboard Layout with it aswell). This can mess with the Archicad Shortcuts maybe.
  • The shortcut: LEFT ALTKEY + SHIFT

    I hit left ALT + SHIFT and it becomes ENG
  • The shortcut: WINDOWS KEY + SPACEBAR
    Keep holding the Windows key and hit spacebar again to toggle language

Further Reading: There is a way to change Windows Settings regarding the shortcut:

Now we have this out of the way, we can check on Archicad itself.

I am not an active Archicad User but i'd check the "Options > Work Environment > Keyboard Shortcuts" Menu.
Then "Show Shortcut List in Browser"

To customise Archicad an its shortcuts to your needs, i should follow this Guide

Keep in mind that not all shortcuts are customisable.
Admin of BIM [Cloud] [SaaS] [Server] | AC 19-25 [Win&Mac Clients] | VM's
Not applicable
Hello and thank you for such an analytic answer. Unfortunately, being a 15 years user in Archicad this has never happened before. I have GReek language as you have Deutsch, and english as well and some times when I learn a new language I insert the keyboard to learn to write it, but in archicad this has never been a problem. In every language the shortcuts worked fine!
Also I went to keyboard shortcuts in archicad to re do them but they are all there it says ctrl + S for save I re enter it but still doesn't work!
Strangest of all: when I write with text tool in archicad I can select all text withing the textbox with ctrl + A but when I am "outside" the text box ctrl + A doesnt work.
I am leaning towards a bug maybe?

you could try to uninstall other languages as this Topic suggests:
Admin of BIM [Cloud] [SaaS] [Server] | AC 19-25 [Win&Mac Clients] | VM's
I think the problem may have something to do with the touch screen. Can you disable it and try if key combinations work then?
Windows 10
Not applicable
Hello. I had the same problem, with Greek language on my keyboard. For me the solution was to make sure that I started Archicad program with ENG language enabled.
Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni
Dear all,

Thank you very much for sharing your experiences about this topic!

This seems to be a problem with Windows 10. Have you seen the discussion in this thread here?

Please let me know if it helps you with the issue!

Best regards,

Minh Nguyen
Technical Support Engineer

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!