Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Keyboard stops working in Archicad 26

joey
Participant

This happens at least once a day. I would be working and all of a sudden my keyboard is unresponsive. If I switch to another open project I already had open the keyboard works. The only fix is to minimize the unresponsive Archicad and maximize it again to get the keyboard working. This is happening to others at work also.

 

Archicad 26 Teamwork

WIndows 10 Pro

NVIDIA GeForce RTX 3080Ti

AMD Ryzen 9 3900X

(3) Monitors

 

 

 

8 REPLIES 8

I never had any good reason to use 26.  Had it installed a while.   Sticking with 25  until after at least the first HotFix for 27.   But pretty skeptical about 27 too.  

ArchiCAD 25 7000 USA - Windows 10 Pro 64x - Dell 7720 64 GB 2400MHz ECC - Xeon E3 1535M v6 4.20GHz - (2) 1TB M.2 PCIe Class 50 SSD's - 17.3" UHD IPS (3840x2160) - Nvidia Quadro P5000 16GB GDDR5 - Maxwell Studio/Render 5.2.1.49- Multilight 2 - Adobe Acrobat Pro - ArchiCAD 6 -25

Lingwisyer
Guru

Given it's a keyboard issue, you should probably state what keyboard you are using as well as your installed keyboard drivers. Basically, default windows keyboard drivers, or if you have additional drivers over the top such as Logitech Options or iCue.

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win10 | R5 2600 | 16GB | GTX1660 
Botonis
Advisor

Do you have a problem with your shortcuts not working? 

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.
joey
Participant

Yes shortcuts do not work also. Entire keyboard unresponsive unless I minimize then maximize the problem Archicad. It's just a generic gaming keyboard. Will try getting a new one and if I remember post an update.

Botonis
Advisor

If this is happening only with archicad then probably it is not the keyboard. If you are changing between languages  when working with archicad before replacing your keyboard try this:

 


- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 xx.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.
JHadley
Beginner

This issue has started happening to me in the last week. I would notice it when I was trying to back out of a command and the esc key wouldn't register. I can tab into other programs and all the different keyboard strokes work fine in those applications, but then when I go back into the ArchiCAD window, no keyboard commands register. I have been going up to file to manually save, closing, and reopening to get everything working again. Haven't tried the maximize and minimize trick yet. Seems to be an annoying little bug though.

Can you try the registry fix.?

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.
russfairhurst
Participant

This happens to me when I accidently select a layout and it highlights the name to rename it. Screenshot - 8_11_2023 , 10_54_46 PM.png deselecting the layout get the keyboard focus back again.

Versions 6.5 to 27
Windows 11 Intel Core i9-13900K RAM 128GB NVIDIA GeForce RTX 4090

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!