Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Upgrade older version

RVMJMCC
Participant

I am a minimal user with V8 on an older machine.

I would like to install a version that functions on a Windows 10 64bit machine. I think V13 or 14.

I don't need support, I simply need to be able to open some really primitive files created a long time ago.

Any suggestions?

5 REPLIES 5

You would need a license to upgrade to a newer version than 8 and if you upgrade the license it would then bring you up to version 26. V8 should still work on Windows 10 in compatibility mode. I am running 10 and 7 on Windows 11 ARM version.

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 27.2.1
macOS Sonoma (14.5)
Eduardo Rolon
Moderator

I think this is a little bit more technical than you think.

IIRC you will need to use a translator for V09 or V10 since Plotmaker was a separate app 20 years ago.

---

https://graphisoft.com/downloads/fileconverter

Eduardo Rolón AIA NCARB
AC27 US/INT -> AC08

Macbook Pro M1 Max 64GB ram, OS X 10.XX latest
another Moderator

I think Archicad 8 files will open in the newest version of Archicad as will the Plotnaker Layout books associated with version 8. The file converters will make anything up to 6.5 work with the newer versions. 

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 27.2.1
macOS Sonoma (14.5)

No, modern versions only open until v10. Everything below to v6.5 needs a converter (a stripped down Archicad v10). Everything below can only be converted by the support.

Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text | My List of AC shortcomings & bugs |

«Furthermore, I consider that Carth... yearly releases must be destroyed»

You're right AC6.5-9 needs to be converted to 10 to be opened to any version above 10. There are File Converter Packages to open files all the way back to 4.1, we have them all so it shouldn't need to be sent to support. There is a package for 7 that opens 4.1 to 4.55 and a package for 9 that opens 5 - 6.

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 27.2.1
macOS Sonoma (14.5)