Choose your top Archicad wishes!

Read more
Modeling
About Archicad's design tools, element connections, modeling concepts, etc.
SOLVED!

Imported point clouds are misaligned

Mike96
Advocate

Hello,
For months I have been struggling with this specific problem:
When importing E57 point clouds a into new, empty model, everything works fine. But as I keep working on a model (add 2D and 3D elements, views, change different settings etc.) and try adding more point point clouds that should stay aligned (e.g. subsequent stories of a building), suddenly one or more stories get kicked a few meters away horizontally.


While importing, I always stick to non-rotated floor plan. The issue is not about rotation but moving, though.
While importing, I always choose to place point cloud's origin at model origin.


The attached model does have this issue. If you import the two attached point clouds together in it, you'll see they are misaligned. However, if you import them into an empty model, they will stay properly aligned.

 

I have found a workaround that utilizes hotlinks. I import point clouds to an empty model, save them as hotlink module, place the module in my old model and embed it (break links), so the point clouds become part of the old model, and then they stay aligned. However, this method takes extra time which I want to save.

 

I always try to avoid transforming (rotating, moving and scaling) imported point clouds in my models. I treat their original coordinates as holy, as I often need to add extra clouds afterwards, and they have to stay aligned. Not to mention how slow Archicad is, whenever you try manipulating a point cloud.

 

This is clearly an Archicad-related problem, because these two point clouds are properly aligned when imported in other sortware, like Cloud Compare or Revit.

 

I noticed one more strange thing that seems related to this issue and might be a clue to help tracking down its root.
A point cloud imported to a new, empty model, based on default Archicad template, has its virtual corners (bounding box marked with black dots) wide just enough to enclose the actual physical span of point cloud object.
When you import these clouds into my attached model, their bounding boxes extend hundreds of meters beyond the cloud's actual size, but only until you change any setting or coordinate of the point cloud object.

 

Below, screenshots how they should look (upper) and how they look (lower):

-2023-mar-1-042.jpg

-2023-mar-1-048.jpg

 

Links to point clouds (they're too heavy to attach them here) - same content in both links, at your preference:

https://drive.google.com/drive/folders/1_3jpf76KT8SPwnO6Annn-EzPtfQxHQ4E?usp=sharing
https://we.tl/t-UzBH0ld6IA

ArchiCAD 25

Windows 10
1 ACCEPTED SOLUTION

Accepted Solutions
Solution

Yes, I actually solved my problem, thanks to following the advice someone gave me in Youbue comments (would you guess that?)

 

So basically, on a fresh model, before inserting any point clouds, you open the object tool (the chair icon), unfold the tool settings (see screenshot) and set rotation to zero. It doesn't matter that you can see furniture there - this setting will be applied to all imported objects from now on. I always check this box before importing a bunch of clouds, making sure there's no pre-imposed rotation.

 

OBJECT SETTINGS.jpg

 Sorry, it's Polish Archicad.

 

However, Midhad, if your point cloud is large (how large? how many point or MB?) and georeferenced, this may also be the issue. Archicad struggles both with big coordinates and big point clouds a lot. In this field, it's way behind Autodesk programs, which handle it way better (both in terms of precision and performance).

 

So I'd suggest checking the object tool rotation setting first, and if it doesn't fix it, we can take a closer look on your cloud. Maybe you could upload a few fragments that get misaligned?


OBJECT SETTINGS.jpg
ArchiCAD 25

Windows 10

View solution in original post

13 REPLIES 13

Hello @Mike96,

 

I tried to import your clouds after merging them.

The cloud seems to be far far away or there are some or one point(s) far from the cloud.

Capture d’écran 2023-03-01 à 13.48.31 (2).png

 

I always use Cloudcompare before importing e57 file into Archicad.

This is an essential step to obtain lighter clouds without loss of data, to assemble clouds, to clean up unnecessary points : furniture, trees, etc.

 

What I get into Cloudcompare (I have transformed scalar into RGB) :

Capture d’écran 2023-03-01 à 13.54.23.png

What I get into Archicad :

Capture d’écran 2023-03-01 à 13.53.56.png

Capture d’écran 2023-03-01 à 13.54.52.png

The e57 file weighs only 25MB 😉 (link below)

Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 27 FRA FULL

OS 11.6 Big Sur - MacBook Pro 2017 - 16Go RAM
"Quality is never an accident ; it's always the result of an intelligent effort" John Ruskin
Miha_M
Advisor

As @Christophe Fortineau does, in CloudCompare I also clean up any given point cloud (using SOR filter, this way any anomalies like very distant points get deleted) and subsample data before importing it in Archicad. The subsampling depends on what the pointcloud represents, with lidar terrain data the min. space between points will be set much higher than on building pointcloud data.

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

Mike96
Advocate

Thank you for your replies, sorry for my late response.

I will try working on point clouds in Cloud Compare, but still, the fact that they are imported properly to an empty Archicad model, but misaligned in a formerly edited model, suggests that the culprit is not the point cloud itself. I always get my point clouds from another worker, prepared ready for use in Archicad, and indeed, they all have correct coordinates, until I try to import them anywhere but an empty model.

ArchiCAD 25

Windows 10

Hello @Mike96 ,
I am wondering if you have found a solution to this problem. I am experiencing the same issue in many projects. Please let me know if you have any solutions. Thank you in advance!

Miha_M
Advisor

I am mostly using site survey or national Lidar point clouds. With all this data I never had any problems aligning the point cloud data with digital plot boundaries, as long as they have been established on the same geodetic datum and the Survey point has been set correctly. I always use a 2D Survey plan and the corresponding point cloud together, as it's the easiest way to check if they match.

 

How much misalignment do you have to deal with? With survey point set or without? Without using a survey point you probably have to deal with the "far from origin" problem, which you'll need to find a solution for (different site-only file as a hotlinked module or a set survey point in your project file).

 

A little point cloud clean-up in CloudCompare is also something worth considering. 

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

I am using a georeferenced point cloud, which is huge in size. I divided it horizontally, with each level representing one point cloud.
This method optimizes performance when working in ArchiCAD. However, after inserting all of them into the project, they are misaligned along the x-axis. In the section view, the misalignment is evident, similar to the example provided by Mike. The misalignment can be up to 30 cm on random sides, either left or right.

Interestingly, when opening the same clouds in CloudCompare, or other cloud viewers, or Revit, everything appears to be in order.

Solution

Yes, I actually solved my problem, thanks to following the advice someone gave me in Youbue comments (would you guess that?)

 

So basically, on a fresh model, before inserting any point clouds, you open the object tool (the chair icon), unfold the tool settings (see screenshot) and set rotation to zero. It doesn't matter that you can see furniture there - this setting will be applied to all imported objects from now on. I always check this box before importing a bunch of clouds, making sure there's no pre-imposed rotation.

 

OBJECT SETTINGS.jpg

 Sorry, it's Polish Archicad.

 

However, Midhad, if your point cloud is large (how large? how many point or MB?) and georeferenced, this may also be the issue. Archicad struggles both with big coordinates and big point clouds a lot. In this field, it's way behind Autodesk programs, which handle it way better (both in terms of precision and performance).

 

So I'd suggest checking the object tool rotation setting first, and if it doesn't fix it, we can take a closer look on your cloud. Maybe you could upload a few fragments that get misaligned?


OBJECT SETTINGS.jpg
ArchiCAD 25

Windows 10

Okay, Mike,

Thank you very much. I will see if this works. I decimated all point clouds to be under 400MB, which is the best option to maintain cloud quality and ensure good performance in ArchiCAD.

I solved this problem by combining all clouds into one and decimating it significantly for better functionality. However, with much larger clouds, this may not be feasible.

Once again, thank you!

Miha_M
Advisor

Try to reduce your point cloud distance from Archicad origin using the Survey point. 

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11