cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.
SOLVED!

Morph in section shows as hollow - any way to assign 'Cut Fill'?

alexliz23
Enthusiast

The Morph is Solid, btw.

 

I have seen Rubia Torres's thread, “Morph object not showing up in "cut fill" properly?” here, but can't see any help resolving this.

Looks good in 3D - not so good in 2D Section:

 

Screenshot 2024-05-20 at 22.00.07.png

Screenshot 2024-05-20 at 22.00.45.png

 

Thanks guys,

Alex

Archicad 27 macOS Sonoma
2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution
Barry Kelly
Moderator

Check the cut surface override in the morph settings.

 

BarryKelly_0-1716251709883.png

 

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

View solution in original post

Solution

If Barry's suggestion doesn't work, the problem could be that your morph is not solid.  You can right-click on the morph and choose 'Check Solidity' to confirm.  If it's not solid you will have to hunt around it and find out where the geometry has become compromised.  This is often caused by lines that are not on surfaces, or faces hidden inside the volume that divide it up into more than one volume.  For a morph to be considered solid the 'skin' of the morph must be seamless (no gaps) and the interior must be one continuous volume...with no subdividing faces. 

Jeff G

Archicad 27 USA (full), Macbook Pro (16-inch 2023, M3 MAX, 128 GB RAM)

View solution in original post

3 REPLIES 3
Solution
Barry Kelly
Moderator

Check the cut surface override in the morph settings.

 

BarryKelly_0-1716251709883.png

 

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Solution

If Barry's suggestion doesn't work, the problem could be that your morph is not solid.  You can right-click on the morph and choose 'Check Solidity' to confirm.  If it's not solid you will have to hunt around it and find out where the geometry has become compromised.  This is often caused by lines that are not on surfaces, or faces hidden inside the volume that divide it up into more than one volume.  For a morph to be considered solid the 'skin' of the morph must be seamless (no gaps) and the interior must be one continuous volume...with no subdividing faces. 

Jeff G

Archicad 27 USA (full), Macbook Pro (16-inch 2023, M3 MAX, 128 GB RAM)
alexliz23
Enthusiast

Thanks both Barry & Jeff.

 

@Barry Kelly - I'm such a doofus, it turns out that the Building Material I'd assigned to the Morph was linked to the 'Air Space' Fill 😢

 

@Jeff Galbraith - thanks for the reminder explaining in detail how solidity can mess things up with Morphs, and yes, if you note the opening sentence above, The Morph is Solid, btw. 😀

Archicad 27 macOS Sonoma