Project data & BIM
About BIM-based management of attributes, schedules, templates, favorites, hotlinks, projects in general, quality assurance, etc.

Custom property used in label not transfering between files

White
Participant

Hi,

After months of browsing and reading the forum, decided to make a first post because I've run into the same issue that has been discussed before in this thread, which is now read-only so I can't respond to it. However, there was no real solution given there, so I'm still wondering if anyone has this figured out.

When I make a custom property to use in a custom label that I've set up by using auto text and saving it as a label, it does not transfer properly to another file. Which means I can't use it in my central office library that's shared between projects.

In another file, it always shows up as #, even if the 'same' property is made in that new file, or even when the property is exported from the original file and then imported in the new one. As described by @Vincent G_ / @Vincent G  in the linked thread:

The only way we found to make it work was to edit a native AC prop (in our case serial number) and replace its data by our expression and then it worked on both files.
So I assumed that any "custom property" created by users get a unique GSID exactly the same way you explicated above with labels, and because of that both files have a identical property but each one is having its own GSID meaning the link is broken.
Does that make sense? If yes, I was wondering how anyone would proceed to create custom property that can be read in different files. I had the same exact problem (label showing #) when I created some property in our template file, working perfectly in the template but not working anymore in a new file created from the template.

 

For now, I'm using the workaround of editing a native AC property that we don't use, but this is not an ideal scenario (and also limited in case we need many more of these).

 

Thanks for any insights!

AC27 on MB Pro M1 Max (64Gb) - OS Monterey
new user since v25
3 REPLIES 3
Yves
Advocate

Hi,
another workaround to this problem... placing the affected label on an element in the original file copying it all.
Go to the new file...paste and the properties will be copied with the same GSID

Yves Houssier
Belgium
Archicad 19 -> 24
iMac - Mac Os 10,13
tonyfitz
Booster

My guess is that the new file you are importing the label to doesn't have exactly the same property as in the original file.  I presume you understand the bit about the GSID, but just in case, when you set the property up in the original file it will have a unique GSID for that property and your label will be referring to this rather than the name of the property.  When you set this same property up in a new file (if it hasn't been carried over from the original file) then while it will look identical in all respects, it will have a different GSID and to ArchiCAD this is not the same property as in the original file.

Therefore the solutions you have are as follows;

 

  1. Make sure the property is set up in your template and the label is referring to this actual instance of the property, then in theory it should carry through every time you create a new file from that template.
  2. delete the property in the new file and import the property from the old file, this should then bring through the same GSID in theory
  3. just link the label in the new file to the property in that file and save that as your favourite for that label.
Tony Fitzpatrick
Head of BIM
www.aw2.fi

Co-Founder / CEO
www.the bimcrowd.com
White
Participant

Hi Yves and Tony,

 

thanks for the quick responses and sorry for the delayed reply but I have been ill for a few weeks after posting this question.

The suggestions helped me clarify the situation.

As suggested, for new files that start from the proper template, there is no issue. My question was intended for an ongoing project that started from a different template.

 

@tonyfitz, your second suggestion is what I tried before and that doens't work by itself, which is why I was wondering about the GSID and if there is any way to organise this for properties the same way you can change attribute index numbers (but it doesn't seem possible? if so, please enlighten me?)

 

in all my trial and error, this is what i found out:

- in the library project file (this could also be the template): create the new property

- draw the label geometry and text fields and save that selection as a label

- export embedded library that now contains the label

- export the new property

>> this workflow does not work when I import the property and library into another file, the same problem persists

>> the only workaround is @Yves suggestion to copy paste the associated zone with it into the new file

 

alternatively, and this does work:

- do the above but save the label in the source file as a favourite

- export the favourite and import it into the new file

>> in the new file it is essential to first import the property before importing the library and favourite, otherwise it doesn't work

 

I'm glad it works out this way but am still curious if anyone could explain why working with a favourite makes a difference, and if there is a way to 'check' if properties in between files are identical through their GSID.

 

Thanks!

AC27 on MB Pro M1 Max (64Gb) - OS Monterey
new user since v25

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!