BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Custom label - Missing settings?


AC23 - Windows 10


Hi everyone,

The first point of this topic is covered already I'm sure, but with this forums update I can't access most of old posts.. Also if this one post is in the wrong section please let me know (cant find the old "Construction documentation").



I had to create a bunch of custom label when native AC ones don't allow me to get the outcome as I don't manage to get a specific label shape + a specific pointer arrow + a specific setting / property on the same time.(to follow office's standard and align with Revit side doco). I did follow AC guide to create these guys from lines, fills, autotext and hotspots

I created a custom label that read wall composite names and keep only the "code" part of the name. The label read a property I created for this purpose. 
For instance a composite named WLE_(161)_18BR/24FC/25FU/76ST/13SPB_W41 will only display the W41 on the tag, and if I end up switching the composite for another, the tag auto update.

The custom label: 

The property: 
SPLIT ( {Property:General Parameters/Composite Structure}, "_", 4 )sc1.JPG

Here are my 2 questions. 

1. (For sure has been answered on old forum) I'd like the label shape to extend according to the text content. I checked on a native label property to try to reproduce that, but on the custom label a lot of parameter are greyed. 

2. I'm working on a project we had to split into 2 file because of the site's level difference. Since both building are almost identical (one project, 2 buildings, one on each file), we created a typical floor plan from building 1's L01 as module that we placed on both files where required. I did add the custom label's layer on the mod, as I'd be happy not to replace and maintain 5 exact same floorplans manually. The problem is that on the file #2 (not the mod's origin file) the label is broken. I got the same issue if I try to copy past that custom label from one file to another. 


Both file got the exact same "Wall type - composite" property with same name, same formula etc. 


I can think of two reason. Either the "custom" property created by users get a sort of specific ID that vary from file to file even if you re-create it the exact same way or have that custom property on the the template, or the custom label needs extra GDL parameter to "find" that property across files. 

Did anyone had a similar issue and found a neat solution?  Worst comes to worst I will manually replace all these labels on each floor plan but what a hassle. 



We've been playing around with a coworker to try finding a solution. We actually managed something. instead of creating a custom label, he somehow managed to get a property label to "look" and behave the same way (shape, pointer+arrowhead ..)

Then we edited the native Serial No property (under Product Info), and we replaced its value by our expression. This time we could export the labels and they were read properly everywhere. 

It seems that it has to do with the user-made property "ID", even if they are made/named the same Archicad does read it as different. Is there any way to get around that?

Vincent G_


In answer to your question one, if you create your own custom marker with a shape, the shape will be a fixed size.

You would need to script a marker yourself - or edit that script to make the shape adjust with the marker size that you can change in the info box or automatically detect the text size and adjust accordingly.

Much easier said than done.


In answer to question 2, these labels are just objects and like any other object they have a unique GSID - the name is basically irrelevant - it is just what we see as users.

So user 1 creates a label and user 2 creates a label with the same name, they will have different GSIDs and so both will show in the label list if you add them to the same library.

Also if any of those label objects are not in a loaded library, they will appear as 'Missing' even though the name is correct.


A new GSID will also be created if you edit and 'Save As' the label - although if you do this you also have to give it a different name if saving to the same location.

Never 'Save As' an object if you have already used in in a file as the already placed instances will not update to the new object -- they will remain as the old object with the old GSID.


I hope that answers your question.





One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry,


Thanks for the feedback. I suspected that about the custom label, some parameter to be added,


About the second part, the problem I have is not really the duplicated label, which makes complete sense with what you just explained. My main concern is that property thing. Following that problem we had my co-worker managed to set the native AC property label as we wanted it to be, so we did not required a custom label anymore. But even so, the property P that we created on file A to read the last part of a composite name is not not working on file B. I mean that the prop label associated to our walls in our typical floor on building A, reading prop P, shows a "#" once we place that module in B. We re-created the prop P exactly the same in B but it did not work. The only way we found to make it work was to edit a native AC prop (in our case serial number) and replace its data by our expression and then it worked on both files.

So I assumed that any "custom property" created by users get a unique GSID exactly the same way you explicated above with labels, and because of that both files have a identical property but each one is having its own GSID meaning the link is broken.
Does that make sense? If yes, I was wondering how anyone would proceed to create custom property that can be read in different files. I had the same exact problem (label showing #) when I created some property in our template file, working perfectly in the template but not working anymore in a new file created from the template.


I have not really used custom properties a whole lot.

Especially not trying to mimic them in separate files.

I think the trick there is that you can 'Export" properties from one file and "Import' them to another.

Maybe they do have some kind of hidden ID (I am not sure).


You will also need to make sure the same classifications are in both files (again you can export/import if need be), because the properties are linked to a classification.



One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Thanks Barry,


I've tried both, create the property on both file or use the export function, ended up with the same issue. I'll have a look at that classification thing as well, but I wouldn't bet on that as a new file created from a template that include a custom property get the same result and I assume in that case both the property and the classification are identical.

I did contact the support about that, i'll let you know if I get any information or explanation. 

Learn and get certified!