cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Project data & BIM
About BIM-based management of attributes, schedules, templates, favorites, hotlinks, projects in general, quality assurance, etc.
SOLVED!

Global origin incorrect

Karl Wir_n
Enthusiast

This is a recurring problem in our office at least since Archicad 15. Sometimes the global origin is no longer in 0,0 in some project files. I have tried to reset the user origin, restart Archicad and selected the "open and repair" option on start.

Everything looks as if the origin is in 0,0 in the plan view but when you drag parts into a gdl-script the coordinates are way off. Anyone who's got a solution to this? The picture is from a project in AC24

KarlWir_n_1-1693214032777.png

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Karl Wir_n
Enthusiast

Thank's runxel for putting me on the track to a solution. It turned out that in the beginning of the project I xref:ed a 2d DWG from another company into the project. At a later stage I bound the DWG to be able to make some changes. I discovered now that in that DWG there were some extra lines very far from the origin. I guess this caused the problem. The solution was I deleted the lines far away, saved, closed and restarted Archicad. Now zero is actually (not virtually) zero again.

View solution in original post

9 REPLIES 9
Barry Kelly
Moderator

If by Global Origin you mean Project Origin, then that is always at 0,0.

It can't be moved.

 

You can however set a User Origin where ever you like.

They both appear as a little cross.

The Project Origin will be grey if you have set a User Origin position.

 

To reset the User Origin back to the Project Origin, double click the 'Set User Origin' button which you can find in the Coordinates Palette (which I think should always be turned on).

 

BarryKelly_1-1693217092758.png

 

 

Then anything you model at the Project Origin such as a hotspot will script with 0,0 coordinates.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Karl Wir_n
Enthusiast

Thank's Barry for your answer but as I wrote I already tried to reset the user origin. That is not the problem. The problem is that although things are placed in 0,0 at the floor plan the coordinates in a gdl-script don't correspond. 

If I copy elements from the corrupted file and paste into a new document (paste into original location) they land in 0,0 on the floor plan and get coordinates 0,0 in a gdl-script. As I wrote this is not the first time we have encountered this problem and I wanted to know If other people  have experienced similar issues.

I have not seen this.

If you place the Coordinate Dimensions object at the Project Origin and a close by User Origin, what does it show?

 

BarryKelly_0-1693228773120.png

 

Has it got something to do with Location Settings or a Survey Point Location?

I have tried playing with those but Project Origin is always 0,0.  for me.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Karl Wir_n
Enthusiast

There is a script at page 432 in the GDL ref. guide (Ac24). With this script you can separate the "world origin" from the "virtual origin" and the "object placement". I don't know what a "virtual origin" is but in my file the world origin differs from the virtual origin. It seems as if the virtual origin is the real 0,0 since if Idrag a hotspot from this point into a gdl 2d-script it reads hotspot2 0,0.

KarlWir_n_0-1693231604783.png

If I place  coordinate dimension objects as in Barrys example it shows this:

KarlWir_n_1-1693231948978.png

 

World Coordinate for use with survey points...

https://community.graphisoft.com/t5/Libraries-objects/World-Coordinate-Point/td-p/252041

or

https://community.graphisoft.com/t5/Collaboration-with-other/Coordinates-and-Orientation/ta-p/303617

 

i think its described in the manual "02 ARCHICAD 24 Reference Guide.pdf"

AllanP_0-1693263087606.png

AllanP_1-1693263372554.png

 

Have you placed any survey information into these files?

 

i don't know if this helps...

 

 

 

 

I have been using ArchiCAD continually since ArchiCAD 4.5, 4.5.5, 5, 5.1, 6, 6.5, 7, 8, 8.1, 9, 10, 11, 12, 13, 15, 18, 21, 22, 25, now testing 27
Member of Architalk since 2003, but missed the migration to Graphisoft.
(where have all my original posts gone?)
Karl Wir_n
Enthusiast

Additional information: no survey point has been placed in the project.


@Karl Wir_n wrote:

 I don't know what a "virtual origin" is but in my file the world origin differs from the virtual origin. It seems as if the virtual origin is the real 0,0 since if Idrag a hotspot from this point into a gdl 2d-script it reads hotspot2 0,0.

 

It's actually the opposite, but let me explain.

The so called "virtual origin" is being placed only when you model your project far from origin. This is being done on opening an affected project as housekeeping (not while having a file open). This virtual origin will then transparently used as an internal offset modifier. This is being done to mitigate all the issues that otherwise would harm the integrity of the project.

So, what do you need to do? –> Model everything close to the real origin point.

See also.

Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text | My List of AC shortcomings & bugs | I Will Piledrive You If You Mention AI Again |

«Furthermore, I consider that Carth... yearly releases must be destroyed»
Solution
Karl Wir_n
Enthusiast

Thank's runxel for putting me on the track to a solution. It turned out that in the beginning of the project I xref:ed a 2d DWG from another company into the project. At a later stage I bound the DWG to be able to make some changes. I discovered now that in that DWG there were some extra lines very far from the origin. I guess this caused the problem. The solution was I deleted the lines far away, saved, closed and restarted Archicad. Now zero is actually (not virtually) zero again.

Probably I have a similiar issue here ... but I don't have those extra lines so not sure what to do now ....
I actually tried to delete everything to see if there is another culprit but nothing changed.

 

JSN_0-1713719784897.png

 

Any other ideas what to try or why this shift of the internal origin is happening?

Edit: Sry, seems like a total reset (meaning, deleting everything was indeed setting the project location back to 0/0/0, just forgot to restart.
Ok, so cool, I just don't know which elements are to blame here but I guess I'll find out ...

JSN_0-1713720521681.png