Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Archicad 25 SNAP GUIDES

Frillex
Contributor

Hello Everybody. 

 

We have finally upgraded to AC 25 (from 22)!

 

Generally I think the version is a little slower then working with 22 but that's not the topic today. 

 

Ever sense GS introduced the new guideline system with snap points and snap lines I've been addicted to the Q-shortcut. In every version sense it came it have always reacted and created a blue line or point for me in an instance.

 

In AC 25 somethings wrong.

It doesn't reacting as I'm used to. Sometimes (if I'm lucky) the Q-shortcut works as fast as it did before. But most of the time it doesn't. 

 

I've check the work environment, the shortcut is not changed in any way compared to AC22. 

 

Have anyone else this problem?

 

I hope I was able to explain. Let me know if you need any clarification 

 

Regards

Felix

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM
13 REPLIES 13

Laszlo Nagy
Community Admin
Community Admin

Are you using AC 25 or AC25 Update 2?

If you use AC25, the first thing I would do is install Update 2 and see if the problem persists.

 

You could also clean Preferences:

https://community.graphisoft.com/t5/Setup-License-articles/Preferences-Cleaning/ta-p/303676

 

Another thing I was thinking of is whether you are working in a project migrated from a previous version. If yes, what happens if you start a brand new project in AC25 based on the default Template and also use the default Work Environment, does the problem occur then? (Just trying to figure out whether it is file-specific.)

 

Also, did you migrate your Work Environment or are you using the default AC25 Work Environment?

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Hi Laszlo! 

 

Thank you for your replay. 

 

Regarding the update, if there's no change from how it used to work:

Went to "help" and clicked "checked for updates" and update.graphisoft.com tells me I'm all upp to date. If it makes a difference I'm using the SWE version. 

 

If it makes a difference i can see from the library that i'm using AC 25.0.0 SWE v1. 

 

I cleaned my preferences about 3-4 weeks ago, and did today just now.. 

 

 

I did not migrate my work environment, "always make a new one" I've been told by Susanne at GS Sweden. Neither is our template migrated, I used the Swedish standard version and made some minor changes to suit us. 

 

Anyhow, after the clean i started a new project and used the standard template with the standard work environment. The problem is still the same. 

 

It's very strange... and frustrating. 

 

I hope that i've misunderstood something about how the updating works and that will solve it. 

 

 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Hi, I had this problem exactly. I tried the usual things and couldn't figure it out. I finally tried turning the Guidelines off and then on in the menu. (See attached) It worked after that and has stayed on. Give it a try.

Cheers,

Gerald
"The simplification of anything is always sensational" GKC
AC 25-4013 USA, CadImage Tools
2019 MacBook Pro 16" w/ AMD Radeon Pro 5600M GPU
OS X 11.6
2.4 Ghz 8 core i9, 64 GB RAM
27" LG 5K Monitor

Hi Gerald, thanks for the help. 

Unfortunately it didn't work for me 😞

 

I can't understand what's wrong... 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Laszlo Nagy
Community Admin
Community Admin

I see.

The slowness may be caused by other things, sometimes other applications.

For example, if I run too many programs at the same time, Archicad starts reacting slow to commands, the Info Box is slow to populate with icons and so on. If I quit those programs that require much CPU resources the problem is resolved.

You could check your Task Manager to see if there are any programs using lots of CPU resources.

Another thing may be an antivirus software. That can also cause slowdowns.

Otherwise I don't have any other suggestions because I do not know the mac too well, I am on Windows.

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Thanks for trying to help me at least. 

I've checked the task manager, all is fine. And everything works as it should. 

I don't use more programs then AC and perhaps safari at the same time. 

 

I will try to reinstall Archicad when I have some time over. 

 

Thanks again for taking the time. 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Nina Sandahl
Participant

Have the same problem, get snap guides but no snap point like Im used to? Also have Archicad swe

Hi Nina, 
So this might be a Swedish problem...

 

I'm going to reinstall the Swedish version, and also install the international version. And compare them. 

 

I'll get back to you here. 

 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Frillex
Contributor

I've now reinstalled AC 25 SWE. No difference, the problem is still the same. 

I've installed AC 25 INT. And i have the same problem. 

 

But as Nina pointed out it's the snap points that's not working. The lines work fine. 
My colleague's new macbook will arrive this Friday, and I'll check if that compute works better. 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Frillex
Contributor

Hello again, 

 

I've been trying to figure out what's happened to the snap points for a while now. 

I don't have access to any windows machines so this is all on mac.

What i can say about the problem is the follow: 

 

If you start an empty template, snap points works fine. It only occurs when working with "larger" projects.

 

I've tried AC 25 int, AC 25 Swe, the problem still persists.

 

I've tried a macbook m1, macbook pro 2016 and an iMac 2020 no difference, snap points still takes ages to create. 

 

Regards

Felix 

 

 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Nina and I can't be the only people with this problem?

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

The blue guide lines and guide circles and spot (small blue circle around a node) (all activated quickly with 'Q' shortcut) are different to the snap points that mark locations along an edge/line.

 

BarryKelly_0-1649254624899.png

 

The blue guide lines and guide circles and spot are all controlled together so if you are getting the lines but not the spots, I don't know what would cause that.

 

Does adjusting the cursor range in the Work Environment affect the guide spots around the nodes?

It might make it easier to find the nodes if the range is larger.

 

Barry.

 


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Thanks for the input Barry, 

 

Adjusting the cursor range does not change anything, unfortunately.

But I took some time to figure out when this happens:

 

When ever i make the first snap point (by clicking Q) AC creates the point in an instant, but for every point I am creating it takes longer to generate. After about four or five created snap points AC refuses to create snap points or it will take more time then it takes for me to manually place two guide lines in the spot I'm interested in.

 

But for some reason it seems to reset if I wait a few minutes with creating points or when i change story or section in the navigator.

 

We didn't use AC 23 and 24, but I do know that I never had this problem in AC 22.

 

Thank you

Felix  

 

 

AC 25

iMAC 27" 2020 - Big Sur
3,8 GHZ 8-Core intel Core i7
16GB RAM

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!