About built-in and 3rd party, classic and real-time rendering solutions, settings, workflows, etc.

Global Illumination in Artlantis

Once i saw (in a demo) that Artlantis 4.5 supported Global Illumination I was hooked. Then when I finally got my own edition of 4.5 and tried it, I was very disappointed.

The global illumination is a whole generation away from being acceptable, or usable. It only works usably in doing a single room scheme.
If you have a building with more than one room (which most buildings do) forget GI in ARtlantis. If you have so much as ONE light fitting that supports it, the entire building including rooms many metres away are filled with light, including the colour of the carpet in the room which has the light.

worse, if you give the Sun Global Illumination , it looks at first as if its an improvement, but you find one room is full of it, and the room next to it, whcih is equally exposed to light has none at all. I tried it with a cutaway building so that all rooms would have the same visiblility to the Sun. Putting a light in one of these with a green carpet turned ALL the rooms in the building to a wierd shade of Green.
Perhaps I am misjudging the Quickview. Perhaps when it renders it gets it right. But in the quickview, its difficult to be convinced that GI is working.

I would love someone to put me right on this - and get it working right.

Thomas Holm

firstly, you cannot judge the final rendering from a Quickview. It's just an orientation figure, varyingly different from the final rendering depending on what you're editing (shaders, lights, etc.), sometimes looking totally weird, but filfilling its purpose which is orientation.

Since Artlantis first and foremost reason for being is speed, you should simply do a tryout render to estimate the final result. If you lower the pixel size and antialiasing options you'll get a fast enough approximation.

Secondly, I agree that global illumination is difficult to understand and control. I try to avoid it in the beginning, using only a few spotlights, spherical lights and sun lights with varying degree of shadow casting % (= how much light penetrates objects) to get as much control as possible. Always watch the light's colour! (Black sucks light 😉 - remember Dwight's advice).
Then add one light source at a time, preferably turning off the ones you've already created to be able to completely control the effect of a new one before bledning them together. Artlantis' speed makes it fairly easy to use several lights.

When you have lighted the scene to a rough finish, start trying out what effects global illumination will give.

Also I think that the Heliodon is good for quick-and-dirty daylight studies, but for better control, turn it off.

Other opinions expected!



Last spring, I posted a problem description regarding Artlantis 4.5.3 at
I haven't seen this corrected yet. Still, I think Artlantis is the best workflow enhancer for an Archicad user, if you're not a full-time 3D renderer.
AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1

Thomas Holm
David, maybe I was a little hasty there. Now, I realise that what you're asking for might be what I get when I turn off shadow casting. Try setting that to 0 for the sun and see what happens (in a Render Fixed view, of course).

AC4.1-AC26SWE; MacOS13.5.1; MP5,1+MBP16,1

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!