Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI Visualizer - Windows

Ancha
Booster

Hello,

 

I did the installation and copied the folders to the correct place (the sd.webui in C and the Add on to the Archicad folder).
But when startting Archicad 27 and opening the AI Visualizer from the Palettes and click on Generate, I get this error about the AI server:

Ancha_0-1700581743243.png

Ancha_0-1700582521851.png

 


What is this and how to make it work normally?

Thank you in advance.

19 REPLIES 19
Ancha
Booster

And this is the error I get when running as admin the run.bat file.

Ancha_1-1700665129324.png

 

How do I get this to work?

No difference even with Intel-card disabled (and running as Admin etc.)

Erik Bjornhage : SwedishChef, ETTELVA Arkitekter, Gothenburg, Sweden
Architect : Digital Development : Graphisoft Cert. BIM-Manager
ETTELVA Arkitekter : Eriks LinkedIn
DELL Precision 5570; i7-12700H; 64 GB; RTX A2000 [8GB] : AC12 - future
Ancha
Booster

Any updates on this?

You should install python 3.10
Download Python | Python.org

The error you are encountering is probably due to dependencies issues or python realated problems.

 

I suggest you the following.

 

Install python 3.10 from the python website, in the installation take care to select "Add Path".

After that you edit the environment.bat in sd.webui folder.

change  the value from 1 to 0 : "set SKIP_VENV=0"

Go to the folder "webui" open the file "webui-user.bat", wait for install. After that close the terminal.

Go to Archicad and try again. Instead of localhost:7680 insert: 127.0.0.1:7680  (or just try both).

 

Is this issue already fixed without getting to know coding?

Earthworm
Booster

Well, as said you need to install Python 3.10.6 -> https://www.python.org/downloads/release/python-3106/

At the end of the page is a lists of links; you'll need Windows installer (64-bit) 

 

Have you done this?

ArchiCAD 27 | Intel Xeon W-2225 - 4.10GHz | 32 GB RAM | GeForce RTX 3080 | Windows 10

Tried this but it didn't work. Sigh....

 

Caitlin Kelley Architect
AC24
MacOS Catalina 10.15.7
2.4 GHz 8 Core Intel Core i9
64 GB Memory
AMD Radeon Pro 5600M 8GB
Earthworm
Booster

Ancha got an error both on GPU and Python.

 

The GPU-error is most likely due to not having the right GPU, it's required to have a NVIDIA Videocard of 8GB or more.

 

The Python error simply means you need to install the correct version of Python.

 

@caitlinkelley, you have an AMD Radeon GPU which isn't supported by the stable diffusion AI-model

ArchiCAD 27 | Intel Xeon W-2225 - 4.10GHz | 32 GB RAM | GeForce RTX 3080 | Windows 10

Thanks for your input. I also run Archicad 27 on a PC with an NVIDIA 8GB.

I'll check that I have the correct version of Python.

 

 

Caitlin Kelley Architect
AC24
MacOS Catalina 10.15.7
2.4 GHz 8 Core Intel Core i9
64 GB Memory
AMD Radeon Pro 5600M 8GB

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!