cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Converting to morph destroy uv maps

jc4d
Expert

Hello,

 

I have made an object in Blender uv mapped, when I import it into ac using collada the textures are fine, but when I convert the object to morph the uv mapping is lost.

 

Am I doing something wrong or is there a way to avoid this?

 

Object right after import as collada:

jc4d_0-1651835105500.png

 

Object after converting it to morph:

jc4d_1-1651835135316.png

 

Juan.

8 REPLIES 8
neilmcallister
Booster

I'm hoping there is an answer to this - I have the same problem importing sketchup objects.

Archicad 26 / Windows 11
runxel
Legend

I do fear that this is not possible at the moment.

Doing UVs (somewhat) correctly can only be achieved in GDL, meaning in an object. As soon you convert that to a morph it won't work.

Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text | My List of AC shortcomings & bugs | I Will Piledrive You If You Mention AI Again |

«Furthermore, I consider that Carth... yearly releases must be destroyed»
jc4d
Expert

I found a "workaround", the main reason for converting a imported model into morph is to be able to hide the unnecessary vertices without dealing with diving into the gdl code as @runxel suggested. Althought it could be great, dealing with texture mapping in the gdl code is a nightmare (sorry for the harsh word).

 

The workaround is to install the Archicad goodies specifically the 3ds import addon, with it you can have a much cleaner mesh representation in the elevations without the messy mesh looking.

 

Of course if you convert it to morph, the uv's will get lost

 

Collada import on the left and 3ds on the right in elevation view:

jc4d_0-1651935656998.png

Juan

 

JohnJay
Expert

How are you exporting to 3ds?

 

And when you import into AC the UVs are maintained?

AC27 | i7990x | RTX4070 | W10

One blender developer has made a 3ds import/export addon.

https://github.com/blender/blender-addons-contrib/tree/master/io_scene_3ds 

 

Yes, so far the object comes into ac as it was in blender, but if you convert it as morph, then the uv maps are destroyed anyway.

JohnJay
Expert

Thanks but I can't get the script to work 😳

 

Which file do I need?  Tried all 3 and combinations of but after attempted install the plugin doesn't appear in the list

AC27 | i7990x | RTX4070 | W10

You have to download the whole folder from here:
https://github.com/blender/blender-addons-contrib

jc4d_0-1653153399268.png

After downloaded unzip and navigate until you see this:

jc4d_1-1653153473793.png

Then drag that folder into your Blender script addons in the AppData, something like this:

jc4d_2-1653153589429.png

And after that launch Blender and it should show in your addons, enable it and ready to go

jc4d_3-1653153642366.png

Hope it helps 🙂

 

Juan.

I am trying a similar workflow, and the Collada format seems to be the best one to maintain textures and geometry. The only drawback being that the object interface does not provide an easy way to remove the edges.

To remove them, open the object GDL script editor (cmd+alt+O), go to the 3D script and Find and Replace (cmd+F) "-1, -1, 0" by "-1, -1, 1" and select Replace All.

When you save the object, the edges will disappear!


Screenshot 2022-10-25 at 03.42.39.png
Archicad 27 ARM, MacBook Pro M3 Max 128Gb, macOS Sonoma.