cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

SEO Interfering with Graphic Override?

Chris Grantham
Enthusiast
I am attempting to simplify some smaller scale sections by just showing all the cut structure with a simple poche. Unfortunately when I attempt to do this some elements that are acting as operators lose some linework. I can't seem to get to the bottom of it, so I have resigned to just show the structure as solid black. I did verify layer priorities as well but that does nothing. See attached images illustrating what I mean. Anyone have any thoughts? Thanks!
16" MacBook Pro M1 Max
Mac OS 12.2.1
ArchiCAD 25 Build 5010
17 REPLIES 17

Hello y Chris Grantham,


Did you try to put your wall in front and your mesh behind ?
Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 25 FRA FULL

OS 11.6 Big Sur - MacBook Pro 2015 - 16Go RAM
"Quality is never an accident ; it's always the result of an intelligent effort" John Ruskin

Chris Grantham
Enthusiast
I did try that initially. It does not help. Thanks!
16" MacBook Pro M1 Max
Mac OS 12.2.1
ArchiCAD 25 Build 5010

Anonymous
Not applicable
Long shot here: Check the SEO operation if you set "Use attributes from the operator" or something like this.
Hope that helps.

Minh Nguyen
Graphisoft
Graphisoft
Hi Chris,

Thank you for sharing the issue!

From the description and pictures, I'm wondering if you have turned on "Show Skin Separators"? As you can see in the attached pictures below, once I have it turned on, the line around the wall and beam will be visible.

Let me know if this helps with the issue!

Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Chris Grantham
Enthusiast
Well that helps but it presents a whole new set of issues with my composite walls. I was hoping to just show a simple grey poche so smaller scale sections read clearly. When I select show skin separators I end up complicating the drawing more than is needed.
16" MacBook Pro M1 Max
Mac OS 12.2.1
ArchiCAD 25 Build 5010

Anonymous
Not applicable
Try the following: On the original section view you are having the issue > Deactivate groups > select only the elements involved in the operation > Copy these elements to a zone far from the original ones > Do the SEO operations again and check if the issue persist.
Hope that helps.

Lingwisyer
Champion
Use a GO to override all of your walls in section to a solid colour?
AC22-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200 RIP PSU
Win10 | R5 2600 | 16GB | GTX1660

Chris Grantham
Enthusiast
The issue persists... not sure what the heck is going on!
16" MacBook Pro M1 Max
Mac OS 12.2.1
ArchiCAD 25 Build 5010

Minh Nguyen
Graphisoft
Graphisoft
Hi Chris,

It turned out that this is a limitation with how we present lines of adjacent element in sections. We keep only the thicker or continuous line when 2 lines are above each other in section. Due to graphic override, the line of the thicker element (which is the wall in this case) is delete. Show skin separator would make the line visible again, but so do all the skin lines, which is not favorable here.

Because of this, I suggest a work around for this situation:
- Set the cut line of the wall in the Wall selection settings with a pen thinner than the Mesh's cut line pen
- Use Graphic override and make sure that the Wall's line pen is overridden with a thick pen

Although this will make the mesh cut line thicker, this will ensure that the separator line is not deleted by GO rule.

I hope this will help you with the issue. Should you have any further questions, feel free to ask me again!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

runxel
Ace
mnguyen wrote:

It turned out that this is a limitation with how we present lines of adjacent element in sections.
I'm sorry Minh, but this is a serious defect!

Have a look at the picture: I'm sure, I'm not alone in that if I would override the elements contours I want them to pop out! But here instead (done with the "thick mesh contour trick") the mesh is much more prominent. Not really what an architect would expect...
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

vdentello
Booster
runxel wrote:
mnguyen wrote:

It turned out that this is a limitation with how we present lines of adjacent element in sections.
I'm sorry Minh, but this is a serious defect!

Have a look at the picture: I'm sure, I'm not alone in that if I would override the elements contours I want them to pop out! But here instead (done with the "thick mesh contour trick") the mesh is much more prominent. Not really what an architect would expect...

wut.png
+1 to that.

I've had some friends asking me about this Line issue, and i wasn't able to fix it. Told them to forward to Graphisoft to see if gathers up some attention.
But the footing Thickest line should prevail, we tend to prefer the terrain with a thinner line settings, as @Runxel Said.
Archicad User Since 2013
GDL Developer
Experimenting with API
from Brazil

Minh Nguyen
Graphisoft
Graphisoft
Hey guys,

I'm absolutely agree with you. This issue has not been fixed for quite a while, due to the complexity of the design questions that arrive with it. I have escalated this issue once more with your comments, hopefully this behavior will be modified in the near future.

Thank you very much for your understanding, and I am very sorry for the inconvenience!

Best regards
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
vdentello wrote:
I've had some friends asking me about this Line issue, and i wasn't able to fix it. Told them to forward to Graphisoft to see if gathers up some attention.
But the footing Thickest line should prevail, we tend to prefer the terrain with a thinner line settings, as @Runxel Said.
Thanks to suggestion from runxel I found this workaround:
1. set a new pen slightly thicker than that used by walls, slab and foundations (I use 0,36mm instead of 0,35mm) for the cut outlines of ground/mesh;
2. use graphic override to replace this pen with the same pen I use for walls, slab and foundations (you can use a smaller one, but you will have this smaller pen between ground and building);
3. use elevation limit and settings to hide bottom and side ends of ground... you'll get the heavy sing on the upper surface of the ground.
Hope it helps, in waiting of Graphisoft solution.

Laszlo Nagy
Community Admin
Community Admin
mnguyen wrote:
Hey guys,

I'm absolutely agree with you. This issue has not been fixed for quite a while, due to the complexity of the design questions that arrive with it. I have escalated this issue once more with your comments, hopefully this behavior will be modified in the near future.

Thank you very much for your understanding, and I am very sorry for the inconvenience!

Best regards
Minh

I think one very simple solution to the design aspect of this would be that thicker lines always overlap thinner lines (kind of like in the case of Priority-based Connections).
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

LaszloNagy wrote:
I think one very simple solution to the design aspect of this would be that thicker lines always overlap thinner lines (kind of like in the case of Priority-based Connections).
This is something I think I've already posted as a wish before through our reseller. There are a few instances with wall connections in plan view, these kind of section things, but also for example placing an object in plan view with a thin outline where I always have to send it backwards 2 steps after placing so the thicker outline of a wall overlaps it.

It does drastically change the way things work now and maybe some people like being able to cover half of a line thickness and so on...
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

PVBergkrantz
Advocate
+1 hoping for a fix for this. I wrote about this problem in another thread and was redirected here. If anyone else is having the same problem as me getting Nguyens temporary fix to work with two graphic overrides, one for the wall cut and one for the ground cut, I finally figured it out: you need show skin separators turned on for the ground cut, as well as a thicker line.
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

kylevfa
Contributor

Has this still not been resolved? I'm currently facing a somewhat similar issue but without overlapping elements. I posted about it in another thread but didn't get any replies so I ended up digging around the forums and found this. 

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!