BIM Coordinator Program (INT) April 22, 2024
Find the next step in your career as a Graphisoft Certified BIM Coordinator!
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Magic wand tool forcing program to crash

Not applicable
I am using archicad23 education version, whenever I use the magic wand tool to create a spline line the program shows the loading icon but it never stops. I have to go to task manager and force quit the program. I was using an Apple Mac when this problem started occurring but have since upgraded to a computer that meets all the system requirements.

Has anyone experienced this problem before? Any help would be greatly appreciated.
Note: ArchiCAD handles splines in a very limited capacity...

How long is your spline, and what are you magic wand settings? Might it just be taking a long time as there is a lot of segmentation?

And when you say "forcing program to crash", is that the program crashing to desktop or you having to force close?


AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660
Laszlo Nagy
Community Admin
Community Admin
So, if I understand correctly, you have the Spline Tool active, and then use the Magic Wand?
So you are trying to create a Spline based on another element?
Can you post a screenshot? Which elements do you use as a basis?
Loving Archicad since 1995 - Find Archicad Tips at
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni
Hi Nathan,

Thank you very much for the report and I am very sorry about the experience!

As Laszlo mentioned, we would like to know a bit more about what exactly happens when Archicad freezes using the Magic Wand. Some screenshots/videos about the issue would be greatly appreciated!

Looking forward to hearing from you!

Best regards,

Minh Nguyen
Technical Support Engineer


Hello. I would also like to comment on this issue. I have been having problems with the magic wand tool aswell, for as long as i can remember. (this is the case for Archicad 22 to 25)


I am working with maps, mostly, and this error is starting to get the best of me.

The program crashes when i want to subtract or add to the shape/contour that i am working on.

i tried to tweak the magic wand settings, but to no avail. 

This error happens if you're working with a slab, a mesh, fill or anything else. 

If you-re doing topographic builds, this error is your worse enemy.


The only slight improvement is to divide the irregular spot you want to add to your fill into smaller pieces... but even then, the program keeps crashing.

Another solution is to draw the contour yourself by hand, but that takes alot of time and feels to be totally inefficient.


I attached an example, and ac25 file and a jpeg. you can observe in the jpeg attachment that once i click spacebar and drag my mouse over the area highlighted with red, the loading circle appears, and after a minute, the program crashes. 

any ideas on why this happens? For example, when i try to fill shapes or contours in adobe illustrator, it selects the contour right away, but i deduce that the programs have different ways of doing and calculating things.


You can try to add to the polygon in the Archicad file and see the results and the error yourself. 


i look forward to hearing from anyone in the Graphisoft team or whoever has a solution to this issue.


Best regards.




Late edit:

-the magic wand setting helps a bit when defining the fill within the area , but the crashing is still ongoing. in other cases. 

-i also tried switching to a much more powerful operating system, but that did not help.


Learn and get certified!