Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

File / program association in Windows 11 (version 26)


I have both V25 & V26 installed. For no apparent reason windows (after latest windows update) has suddenly decided that all .pln files are a mystery to it and does not even recognize V26 as a possibility.


I can open files in V26 okay by using the open command in Archicad but I can't double click on the file in explorer to open it (I just get a message that this file does not have any software associated with it). Even old V25 files won't open in V25 if I double click.


Using right click, properties and searching for a program to associate with the .pln doesn't work either. I can see V25 as an option but when I search for and select V26 it just defaults straight back to V25. I had this issue when I had V24 & V25 installed as well and solved it by uninstalling V24. I'm not quite ready to uninstall V25 - is there any other potential fix for this annoying issue?

V12-V25, PC: Ryzen 9 3950X, 64g RAM, RTX5000, Win 11


Does "always open with" do not work for you? Don't know if there is still the checkbox in Win 11 but I guess so.

But the file association on Windows was always a big pain, especially when you installed more than one version; GS never managed to do this completely right.

Mostly AC 26 on Mac | Author of SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Laszlo Nagy
Community Admin
Community Admin

There is the solution where you uninstall and reinstall Archicad 26 and the file associations will be recreated by the Archicad installer. Actually, you may not even have to uninstall Archicad, you can just repair the installation by rerunning the installer. But you need to try it as I do not know if the installation repair would repair the file associations as well (my guess is that it will).

Get Archicad Tips at
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

The open with option didn't even offer V26 as an option and wouldn't allow it to be selected.

V12-V25, PC: Ryzen 9 3950X, 64g RAM, RTX5000, Win 11

I tried this and it worked. I just ran the repair option without uninstalling first. Thanks!

V12-V25, PC: Ryzen 9 3950X, 64g RAM, RTX5000, Win 11

If you repair the installation, you must also reinstall the hotfix package. I think it is better to use the "always open with" option in explorer.
Separately, you should run the "register.bat" file as administrator (from here: C:\Program Files\GRAPHISOFT\Archicad 26\GRAPHISOFT Shell Extension) to make explorer can show the Archicad "info" table.



4.1 - - -

The 'always open with' function was not working (it wouldn't recognize V26). After doing the repair yes I ran the hotfix update as well of course. Everything works as it should now.

V12-V25, PC: Ryzen 9 3950X, 64g RAM, RTX5000, Win 11

Barry Kelly

I think also to re-associate an Archicad version as the default to open with, you can just run the 'Register.bat' file that can be found in the 'Graphisoft Shell Extension' older in the program folder.

This should save re-installing everything.

I'm not sure if you have to restart your machine afterwards.



One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10


In explorer, you can mark the location of Archicad if it doesn't find it on its own. Running a full installation for a two-click problem is a "firing a cannon at a sparrow"

Sorry my win is HUN:




4.1 - - -

I'm sorry I'm not sure what you mean. I am aware of the usual way to direct a file to open with a selected program but this usual method did not work in this case. I have fixed the problem now anyway. I didn't do a full install I just ran the 'repair' install and it was quite straightforward.

V12-V25, PC: Ryzen 9 3950X, 64g RAM, RTX5000, Win 11

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!