cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Archicad Python API
About automating tasks in Archicad using the Python API.
SOLVED!

Python Palette not showing

Josh Verran
Advisor

As per the link below, I have installed the latest version of python.
I've then opened Archicad 26 (also 25), gone into the Work Environment > More options and enabled the python palette under experimental features.
When I navigate to Window > Palettes, the Python palette does not show.
Have closed and opened AC but get same result.
Any suggestions?

 

https://community.graphisoft.com/t5/Project-Management-articles/Python-Connection-in-Archicad/ta-p/3...


GRAPHISOFT CERTIFIED ARCHICAD BIM MANAGER | LinkedIn | My Top Wishes


ARCHICAD 18-27 | BIMcloud Basic | CI Tools | Grasshopper - Rhino | CloudCompare | Bluebeam


Perth, Australia and Tauranga, New Zealand


Windows 10 Pro | Intel Core i9-9900K @3.60GHZ | 32Gb RAM | 2xSamsung S27F350 1920x1080 60Hz | Nvidia Quadro P2200 (5Gb)



1 ACCEPTED SOLUTION

Accepted Solutions
Solution
PeterPetersen
Booster

I had the same problem with AC 25 and AC26.

To show the palette I had to add it manually in the Work Environment / Management - Pallets. See screenshot below (Swiss version):


Python_Palette.jpg

View solution in original post

5 REPLIES 5
Djordje
Ace

check your Work Environment

Djordje



ArchiCAD since 4.55 ... 1995
HP Omen
poco2013
Mentor

Python palette is usually at the very bottom of the list . Did you double check that it hasn't scrolled off the screen? Also check that Python,exe is in your Path?

 

Gerry

Windows 11 - Visual Studio 2022; ArchiCAD 27
Laszlo Nagy
Community Admin
Community Admin

Do you have SSA/Forward? This page says it is feature that is part of the Forward offering:

https://graphisoft.com/forward

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Solution
PeterPetersen
Booster

I had the same problem with AC 25 and AC26.

To show the palette I had to add it manually in the Work Environment / Management - Pallets. See screenshot below (Swiss version):


Python_Palette.jpg

Josh Verran
Advisor

I must have put the above on the back burner and forgot about it.
I tried again today in AC27 and got same issue (Enabled palette under experimental features).

Manually adding the Python Palette option to the Menu worked thou.


GRAPHISOFT CERTIFIED ARCHICAD BIM MANAGER | LinkedIn | My Top Wishes


ARCHICAD 18-27 | BIMcloud Basic | CI Tools | Grasshopper - Rhino | CloudCompare | Bluebeam


Perth, Australia and Tauranga, New Zealand


Windows 10 Pro | Intel Core i9-9900K @3.60GHZ | 32Gb RAM | 2xSamsung S27F350 1920x1080 60Hz | Nvidia Quadro P2200 (5Gb)