cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Collaborate forum

Ifc placed with hotlink has errors in geometry

GOBA
Booster

Hi all!

 

I tried to place an Ifc using “General import” translator and the geometry is incorrect.

 

Archicad_IFC_STRUBIM_STEEL.png

 

Using “Exact geometry” it’s correct, but I would like that architects can see the information, so I would like they use the other translator.

 

I spoke with SIMBIM (Spain) and they told me they needed the exportation schema, but I don’t have it and I haven’t been able to obtain it from the software company.

 

I have the Ifc file expecting someone from  Archicad would be able to see what’s happening. I think all the necessary information is in the Ifc file:
https://www.dropbox.com/s/b4qjkas3ihz6t07/E0012_StruBIM%20Steel.ifc?dl=0

 

ArchiCAD user since November 2109
AC24, Windows 10
13 REPLIES 13

Miha_M
Advisor

I get the same results. Also importing as exact geometry (morph or object based) works. In Solibri anywhere the model looks ok.

Which information would you like the architects to see? I don't see any information missing in the exact geometry import - I used the object based one.

Miha_M_0-1674406018689.png

 

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

GOBA
Booster

Hi Miha!

 

Thanks, I’m not sure what I could have different in the “Exact Geometry” translator but I think it’s correct.

 

xcUSACT

 

 

The thing is I don’t know how to select each element as you do because all the model is 1 object.

 

6yyycv3

 

There is something I suppose I’m not doing ok.

ArchiCAD user since November 2109
AC24, Windows 10

GOBA
Booster

Is it possible that you are in an independent file?

ArchiCAD user since November 2109
AC24, Windows 10

Djordje
Mentor

In general:

We rarely directly link the IFCs directly into our master models.

We usually link them into an empty PLN started from our template, troubleshoot there, save, and then link into the master file as a Module. Best of both worlds, as you can edit it in the individual file, update the IFC if needed (link if you expect revisions, open if you don't), manage objects, layers, remove rivets, nuts, bolts, and washers (quite necessary on a 24 000m2 distribution facility...), have LOD reference MVOs and layer combos, etc...

The Info is still present, and the scheduling works.

Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

GOBA
Booster

Ok, thanks!!!

 

But the initial question remains, because in the empty PLN geometry is not correct. I would like to know if there is a problem in importation or if in the ifs itself (so I would speak with the other software company.

ArchiCAD user since November 2109
AC24, Windows 10

Miha_M
Advisor

I had it opened in an independent file, true. Imported through exact geometry (object based) so imported elements are translated into library elements. As @Djordje noted, using an independent file and linking that one to your project does make life easier.

 

Based on what I can see from your post maybe you only have to suspend groups, then you can select each element?

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

Miha_M
Advisor

You can and should set the IFC translator settings. For "General Import" you have some options for geometry conversion and it was the "Parametric Construction and MEP Elements" option for me which produced geometry errors. If you switch this one to "Objects" you should get correct geometry conversion. This way you get the same settings as the  "Exact geometry" translator has - im my case on v26 INT.

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

GOBA
Booster

Ok, thanks, I see what you mean. Beams, columns are now objects. So once I import with “General Import > Objects”, I suspend groups. If the architects want to see if a beam is an IPE xx they need to open the dialog and consult the properties.

 

When elements are imported as native, only placing the mouse over the element, a box shows this information (I think this is much better). But due to the incorrect geometry, this is not the way.

 

So, I don’t really know why this is happening, I am not going to be able to improve it, but at least there is a solution.

 

Thanks!!

ArchiCAD user since November 2109
AC24, Windows 10

Djordje
Mentor

Is it possible that this is a bug in the Translator/import process that was not noticed until now?

Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!