cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Quotation marks in expressions and schedule dimensions

ocamorlinga
Booster

I was trying to figure out how to add a quotation mark ( " ) within a string, but couldn't find anywhere in the forums or in the expression documentation on how to do it. In case anyone else out there runs into this, you need to type in an escape character, in this case the back slash "\", in order to type the double quote. So for example, if I want to append -0" to the end of a string, I would use:

 

CONCAT ( "string", "-0\"" )

 

But on another note, the whole reason I was having to mess around with this was because my schedules are not showing the dimension conventions I have set. I am using expressions to show jamb size and leaf size, but the dimensions shown do not follow my settings for the schedule.

 

For example:

If a dimension is less than a foot, do not show 0' before the inches. ( 0'-3" will show as 3")

If a dimension does not contain inches, show 0" after the feet. (3' will show as 3'-0")

 

This works great in floor plans, sections, elevations, etc., but not in my schedules where expressions are used. Is there any way to fix this without having to do some crazy expression string gymnastics? I've already figured it out but if anyone knows an easier way to do this, or what setting I need to change, it would be great to know.

 

Actual:

ocamorlinga_0-1652280085289.png

 

Desired:

ocamorlinga_1-1652281185731.png

 

Thanks!

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT
3 REPLIES 3

When you want 3" then ' 3" ' if you want 3' then " 3' "

Maybe in GDL, but working with expressions for properties this throws a syntax error. The " 3' " is correct for 3', but to show 3" it would be "3\"".

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

Laszlo Nagy
Community Admin
Community Admin

@ocamorlinga wrote:

If a dimension is less than a foot, do not show 0' before the inches. ( 0'-3" will show as 3")

If a dimension does not contain inches, show 0" after the feet. (3' will show as 3'-0")

 

This works great in floor plans, sections, elevations, etc., but not in my schedules where expressions are used.

 

I think the reason for this is that what is displayed in schedules is controlled by format settings et in the "Calculation Units" Preferences, and not the "Dimension Units" Preferences. And "Calculation Units" Preferences do not have settings for hiding zero wholes and decimals.

Would be a near feature so you should make a wish for it:

https://community.graphisoft.com/t5/Wishes-forum/bd-p/ideas

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!