cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

View Map & Layout rotation are not the same

Johann_P
Advocate

I have an orientation and zoom saved for my View Map plans.

So when I open my View Map, it opens to the correct orientation.

 

But when I place the views onto my Layout, the orientation is different, even though the orientation is set to 0deg.

 

Anybody care to point me in the direction to fix it?

 

Archi228.jpg

 

 

Archi229.jpg

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000
1 ACCEPTED SOLUTION

Solution

I hope the attached video helps you, tried to make it more direct how things work though needed to split the video seems that this website got limitations in terms of files size when attaching. 😎

In the end what is your Objective?
ArchiCAD 9 onwards

View solution in original post

12 REPLIES 12

4dProof
Expert

are the view settings in the view map set to "ignore zoom and rotation"? IMO, this should almost ALWAYS be unchecked

 

BIM solutions and trouble shooting (self proclaimed) expert

Yeah I agree with you. It always messes up with the layout orientation when this is checked... Also trying checking your model view orientation if you saved it under the correct view map, sometimes can be overlooked. 😎

In the end what is your Objective?
ArchiCAD 9 onwards

Patrick Hayes
Contributor

As above it looks to be a view setting thing, not the drawing settings. Your view should have a rotation saved and the ignore thing should be unticked.

PatrickHayes_1-1649834419409.png

 



Also on a side note, if you are placing a drawing, you want 99% of the time for the drawing to be anchored by internal origin. Otherwise your drawing will forever dance around the layout if you add anything beyond your most distant element because it's anchoring to the "centrepoint" (which it calculates) of the extent of all elements in that view if you use the dot anchor method - eg if you draw a line off to the side of your project workspace to work something out. The dotted anchor points are only useful (in my opinion) on shedules placed on drawings where you have them set to Auto fit frame.

 

Will save you scratching your head when you think... I'm sure I didn't crop that bit of the drawing!

PatrickHayes_0-1649833733402.png

 

Johann_P
Advocate

Thanks.....
But I'm still not getting it right...

@4dProof 
Yup, the View Map "ignore" is unchecked.

 

@ryejuan 
I'm not sure what is meant by "model view orientation" unfortunately.

 

@Patrick Hayes 

I have checked and unchecked the "Internal Origin" setting, and it doesn't seem to make a difference.

 

So....

I created a new Layout to test this, and:

 

This is the View Map.

Archi230.jpg

 

 

 

Then when I drop the View Map onto the Layout both the orientation and "zoom" is different. Most of the plan is cut off in the crop.

Archi231.jpg

 

 

So if I stretch the crop, I can at least see the plan, but the orientation is still wrong.

Archi232.jpg

 

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

Can you post a screenshot of the "quick options" palette when you are in your saved view - this should show the rotation of the view in the view map.

 

Then, can you show a screenshot of the drawing settings in the layout.

 

This will help diagnose what's happening.

 

Also, you won't notice any changes with the internal origin selected as opposed to the central anchor dot selected right now. It will just be something in the future where your drawing may change it's position on your layout as you do further drawing in your view. (Only usually moves by a little bit but very annoying amount) so you are correct in experiencing no changes right now in checking that tick box. Just keep it set to internal origin and all will be well. 

Hi @Patrick Hayes 

 

Couple of screenshots.

1st) Shows the saved View Map.

- With Quick Options open.

 

2nd) Shows how it arrives in Layout when I drag & drop it.

- cropped with different orientation.

 

3rd & 4th) Shows with the settings open.

I highlighted the "Internal Origin" before I read your whole email....

 

 

Archi233.jpg

 

Archi234.jpg

Archi235.jpg

Archi236.jpg

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

Solution

I hope the attached video helps you, tried to make it more direct how things work though needed to split the video seems that this website got limitations in terms of files size when attaching. 😎

In the end what is your Objective?
ArchiCAD 9 onwards

Johann_P
Advocate

@ryejuan 

Ok, so this is embarrassing.....

I usually do the "Redefine with current window settings" every time I make a change.

 

Considering that the plan opened in the orientation and view I required in the View Map I guess made me believe I've already done the "Redefine with current window settings"

 

But after watching your videos (thanks for that) I did the "Redefine with current window settings" anyhow, and the View Map to Layout orientation and crop is now correct.

 

But as a question:
I understand the link as per your videos.

But why would the View Map open in the saved orientation and zoom but not translate to the Layout Book?

I understood that the view saved in the View Map is the same as what is shown in the Layout?


Thanks everyone.
(No allow me a minute to do face palm in silence......lol)

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

@Johann_P 

Yes, what you save in your view maps is what is displayed in your layout book.

In terms of organization you need to sort your view maps that will relate to what layout you are displaying. Yes you can always get current window setting but what if you are sending your drawings to different disciplines that require different set of  scales, layer combination, graphic override, etc. you can't use one view map and later down the road it will get more confusing if you don't organize your view maps (base on experience)

For me I would always set my layout first (determine paper size scale etc.) then set the views (even roughly) then i would start working on my design from there. You can easily control the views later on, 😎

In the end what is your Objective?
ArchiCAD 9 onwards


@Johann_P wrote:

But as a question:
I understand the link as per your videos.

But why would the View Map open in the saved orientation and zoom but not translate to the Layout Book?

I understood that the view saved in the View Map is the same as what is shown in the Layout?


The Drawing in your images is set to Manual Update so it wont updated to reflect changes to the linked view unless manually done.

thesleepofreason_1-1650371798888.png

 

 

Thanks @thesleepofreason 

For me to understand:

Does that mean,

1) once I've placed a View Map onto a layout,

2) then delete the View Map from the layout,

3) and then place the same View Map again

That the Layout will remember the orientation etc of the first deleted View Map?

 

Because that is what I was doing:

Deleting the old, placing the new, and the NEW view map was not showing correctly.

 

Am I laboring this point too much?
I understand the working of what everybody has said, and still find what happened confusing....

 

Anyhow....
It works perfectly now.

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

Johann_P
Advocate

Thanks @ryejuan 

Good advice to start with the layouts.

I'll do that in future....

ArchiCAD24 - since Nov 2020
Revit - 2005 to 2020
Windows 10 Pro
2 screens: nvidia quadro RTX 4000

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!