BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Save Archicad 27 to 26

joelsdg
Enthusiast

I think I recall having this issue a long time ago, with previous versions, but it's back in AC27 and I don't remember if/how I solved it in the past.

When I try to save a project I started in a previous version of AC (let's say AC22), had been using it in AC25 and AC26 without issue and brought to AC27 yesterday.  No problems until I tried to save it back to AC26.  I receive the error: "Cannot Save Plan file". The only option is to click OK.  No explanation of what caused the problem. If I click OK, I'm just returned to the last window I was in when I started the "Save As...".

 

I tried a few different things:

Close the file and open with "Open & Repair" option checked.

 

Deleted various 2D elements (I was mostly interested in saving the 3D parts for someone else to use in their AC 26).

 

Opened a clean "Archicad 27 template.PLN" and then Merge the original AC27 file I wanted to eventually save to AC26.

 

I opened a project I had in the AC27 Preview format, opened it in the official AC27 release, but still couldn't save to AC26.

 

I opened another project I started in AC26, saved in AC27 but still couldn't save back to AC26.

 

I received the same error every time.  And the AC26 version of the file I brought into AC27 just a day earlier saved back to AC25 no problem.


Anyone have any ideas why this is?

It is a rather large file (1.75GB) in my opinion.  And has a few different hillside terrain models to go with the house that are over 2.5 acres (over 11,000 square meters) each.


Is this a bug?  It doesn't crash, it just won't save to AC26.

The attached file is just a screenshot of the error message.

 

Any help appreciated,

Joel

 

Screenshot 2023-10-12 at 5.23.06 PM.png

AC 6.5-26; macOS Ventura; 2019 MacBook Pro 2.4gHz, i9
11 REPLIES 11
Barry Kelly
Moderator

I am not sure, but is it an issue of where the file is being saved to?

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
rbtubby
Participant

I've also come across this issue.

I have tried to back-save from the desktop to the desktop and had no success.

I made sure the new file would have had a unique name, and also ensured that no space characters, nor any other special characters were used. Still no luck.

I get the same pop-up message: "Cannot save Plan file".

AC27 3001 AUS
macOS Ventura v13.5.2
MacBook Pro (16-inch 2021)
Apple M1 Max
TDabney
Enthusiast

That's interesting... I was able to back save a project from AC27 to AC26 last week. It was project that I had started anew in AC27, not one that I'd started in an earlier version and migrated upwards. I wonder if that made the difference for my success? 

Best,

Tom

TND Architects P.L.L.C.
macOS 12.7
2021 16" MacBook Pro
Apple M1 Max
ArchiCAD 26/27

I haven't tried changing the Save As... location, but I did make sure it had a different name and that all of the permissions were valid (we're a MacOS office).  And I see someone else tried changing save locations, and it didn't matter.  

I also didn't have trouble saving an AC26 version of the same project in the same location back to AC25.

AC 6.5-26; macOS Ventura; 2019 MacBook Pro 2.4gHz, i9

You may be onto something there, but all of our projects start from whatever version we're on at the time.  Then I migrate up as Graphisoft updates the software, as each project allows or not.  

 

Otherwise, I'm assuming I'd have to recreate everything all of the custom linetypes, fills, wall composites, etc. every time I moved to a new version of Archicad.  I've assumed wrong in the past, but that's my first inclination of doing such a thing.

 

Joel

AC 6.5-26; macOS Ventura; 2019 MacBook Pro 2.4gHz, i9
TDabney
Enthusiast

I think you're generally correct that you have to do a lot of recreating if you're not migrating from an earlier version. I use attribute manager to do a lot of it for me, but it still takes time and some level of diligence to bring a "new and reset" project up to speed. Every so often, I use upgrading as an opportunity to go through my typical project template and sift out accumulated unused layers, line types, materials, surfaces, composite etc... to trim down all the stuff I have to scroll through to find what I need while working w/in AC... I try to do that when I know I have some free time and am not under a time crunch, because it can be a long tedious process!

 

Best,

Tom

TND Architects P.L.L.C.
macOS 12.7
2021 16" MacBook Pro
Apple M1 Max
ArchiCAD 26/27
Robby
Booster

Yep- I have the same problem. 

I tried with several files with different complexities but made no difference.

Rob Marelli-
AC 26 & 27
MacBook Pro (2021) M1 Max -32 Gb RAM - Sonoma 14
pnguillen
Contributor

I'm experiencing the same issue;

if someone already figured out this flaw and could help me out back saving my current 27 file to 26; i would trully trully appreciate it  

 

https://www.dropbox.com/scl/fi/hxoebwqegl11n4ub4f1b8/Muhlen_Sept262023.pln?rlkey=76scj11fa5fgm2d9mks...

 

Thanks in advanced

 

 

Hi pnguillen,

 

Here is a link to your file converted to Archicad 26, and the method to do it yourself is as follows:

https://graphisoft.sharefile.com/d-sf9cf0c637a5c4eb4aab8295d1f9dc6e9

 

Open the file in Architect 27 and then open up the Library Manager

Click on your embedded Library, select all items on the right-hand side of the box then the Export button down at the bottom.

Check the folder to be sure that all Library parts were exported properly.

Go back to Archicad 27 and delete all contents of the Embedded Library.

At this point the project should save back to 26 successfully.

Open the file on Archicad 26 to confirm everything saved back as expected. 

 

As an additional note, open the Library Manager and click the migrate libraries button to roll back the library parts Archicad 26 items instead.

 

All the Best,

Henry Berger

Senior Technical Support Engineer

Graphisoft North America

AC 4.1-27; macOS Ventura; 2021 MacBook Pro Apple M1 Max

 

Learn and get certified!