cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Lock view extent for CineRender on different computers

PVBergkrantz
Expert
Hello. We just discovered a big issue when it comes to rendering 3d views on different computers: the extent of the picture is in part determined by the proportions of the screen/window.

If the view is set with specfic dimensions in the PhotoRender settings, this very same view will crop differently depending on the proportions of the specific users window or screen. It even makes a difference if the user stretches his toolbars a bit, thus changing the size of the viewport window. See attached picture for a clearer explanation. This is a huge issue if you are doing renderings and then photoshopping or doing other changes to the images in post processing, and rely on just changing the base image without shifting the perspective.

It is unsustainable to rely on a single computer/user/workspace setup to render images. Does anyone have a method or a workaround to avoid this, or is there something I am missing in terms of locking a view to an exact specific view.
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

12 REPLIES 12

Hello PVBergkrantz,

It seems to be weird !
I do not make the same observation on macos computers.
Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 26 FRA FULL

OS 11.6 Big Sur - MacBook Pro 2015 - 16Go RAM
"Quality is never an accident ; it's always the result of an intelligent effort" John Ruskin

mikas
Expert
It's Render Safe Frame.
It's been talked about earlier here i n forum discussions.

https://helpcenter.graphisoft.com/user-guide/89223/
Render Safe Frame

Turn on this 3D view feature at Document > Creative Imaging > Render Safe Frame.

This is an ARCHICAD mode that affects the 3D window; it displays a frame that indicates which part of the model will be rendered.

This might not be obvious, because the output is affected by the Size setting in Render Settings. Depending on the Size settings, your model could be cut off in the render.

See Set Size.

The Render Safe Frame gives you feedback on this and a chance to adjust the Size parameters.

Note: The Render Safe Frame setting to OFF corresponds to Rendering Settings from ARCHICAD versions 17 and older. In this situation, the full content of the 3D window - even content that is not visible on screen - will be rendered, with its size determined by Render Size.

This setting (whether Render Safe Frame is applied or not) is noted in the 3D Only panel of View Settings and on the 3D Visualization toolbar.
AC25, Rhino6/7+Grasshopper, TwinMotionMac Pro 6,1 E5-1650v2-3,5GHz/128GB/eGPU:6800XT/11.6.5 • HP Z4/Xeon W-2195/256GB/RX6800XT/W10ProWS

David Maudlin
Virtuoso
PVBergkrantz:

One option: right-click on the 3D Window Tab and select "Undock Tab", this will open a separate window for the 3D view. Now use the "Set Window Size..." command to set the Width and Height in pixels for the window. This way the same window size can be set on the various computers. There is a "Dock Window *" command to return the window to the Tab bar when done.

David
David Maudlin / Architect

www.davidmaudlin.com

Digital Architecture

AC26 USA • iMac 27" 4.0GHz Quad-core i7 | 24 gb ram • MacBook Pro 2.8GHz | 16 gb ram • OSX10.15.7

PVBergkrantz
Expert
Thank you for the effort but none of the suggestions work.

First of all the render safe frame seems only to be a visual guide, telling the user what will be shown in the final picture, and I had it turned on in the original screenshots (the grey area covering the sides/tops of the view). This does nothing to "lock" the view, and a render with it turned on or off gives the same result. In my version there seems to be slight difference from the documentation, instead of Document > Creative Imaging > Render Safe Frame it is Document > Creative Imaging > APPLY Render Safe Frame. I don't know if this makes a difference.

The idea with undocking is a smart one that might lend some consistency but I do not have the same option to undock as you. I can click the minimize button to "undock" the 3d window, but from there I can not change the size of the window.

Have anyone else been able to confirm the same issue, or should I assume its just for us?
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

mikas
Expert
Ok, I found it: The earlier discussion, if you want to check that out.
https://archicad-talk.graphisoft.com/viewtopic.php?f=3&t=67469&hilit=render+safe#p300230
AC25, Rhino6/7+Grasshopper, TwinMotionMac Pro 6,1 E5-1650v2-3,5GHz/128GB/eGPU:6800XT/11.6.5 • HP Z4/Xeon W-2195/256GB/RX6800XT/W10ProWS

PVBergkrantz
Expert
mikas wrote:
Ok, I found it: The earlier discussion, if you want to check that out.
https://archicad-talk.graphisoft.com/viewtopic.php?f=3&t=67469&hilit=render+safe#p300230
Thanks for the reference, seems the going solution is that the program works like this, and not much to do about it.
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

David Maudlin
Virtuoso
PVBergkrantz wrote:
The idea with undocking is a smart one that might lend some consistency but I do not have the same option to undock as you. I can click the minimize button to "undock" the 3d window, but from there I can not change the size of the window.
You are correct, the "Undock Tab" command is Mac only. You could right-click in the 3D Window and get the "Set Window Size..." command in the context menu. On my machine this undocks the window and sets it to the inputted size. I cannot test this on a Windows machine.

David
David Maudlin / Architect

www.davidmaudlin.com

Digital Architecture

AC26 USA • iMac 27" 4.0GHz Quad-core i7 | 24 gb ram • MacBook Pro 2.8GHz | 16 gb ram • OSX10.15.7

PVBergkrantz
Expert
David wrote:
PVBergkrantz wrote:
The idea with undocking is a smart one that might lend some consistency but I do not have the same option to undock as you. I can click the minimize button to "undock" the 3d window, but from there I can not change the size of the window.
You are correct, the "Undock Tab" command is Mac only. You could right-click in the 3D Window and get the "Set Window Size..." command in the context menu. On my machine this undocks the window and sets it to the inputted size. I cannot test this on a Windows machine.

David
The command is there for me but clicking it does nothing, at least not on my Windows 10. This is a pity, I like the features of Cinerender a lot but this is a big flaw, I'll report it to Graphisoft and maybe we'll get lucky in ArchiCAD 35.
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

Carstenem
Expert
On windows 7 right click on the 3D tab and choose the set windows size will undock the 3D window just as on a Mac.

Cheers Carsten
Carsten



Youtube:https://www.youtube.com/asmtechbase

www.asmtechbase.com

AC 3 to 26 -Windows 7 - 24GB - 8core 4.4Ghz

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!