Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Archicad 21 slow

KeesW
Booster
I am using AC21 on a small project and find some of its operations much slower that I am used to in previous versions. When I select la working on a model, the scrolled list takes measurable time to appear. When I scroll this list up or down, it takes measurable seconds to actually scroll and it stops and starts. The response to menu selections is also sometimes tardy. I've never had this with previous AC versions.

Am I alone in finding this?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M
21 REPLIES 21

alemanda
Beginner
No, you're not alone
I'm working on 150mb file project. Not big.
When I pass from a view to another view it takes up to a couple of seconds (and more in many cases) to redraw the plan ... I'm a bit disappointed. I bought a new machine in June with many cores in order to exploit the multi tasking but what I see a normale "behaviour", just a couple of cores working except for rendering where it runs all the cores ...
In order to speed up the things I had to disable the background update.
I found AC21 much slower than AC19 (never tried AC20).
Hope next versions will be faster and will be really multi tasking.
AC 19 and AC21 latest hotfix
Win 10 Pro 64bit
Double XEON 14 CORES (tot 28 physical cores)
32GB RAM - SSD 256GB - Nvidia Quadro K620
Display DELL 25'' 2560x1440
www.almadw.it

alemanda
Beginner
what kind of cleaning did you performed?
AC 19 and AC21 latest hotfix
Win 10 Pro 64bit
Double XEON 14 CORES (tot 28 physical cores)
32GB RAM - SSD 256GB - Nvidia Quadro K620
Display DELL 25'' 2560x1440
www.almadw.it

Link
Advocate
You could try this: https://bim6x.com/blog/speeding-your-performance-archicad-21

But to be honest we are experiencing some speed issues that we're trying to get resolved also.

Cheers,
Link.
Get your ARCHICAD 25 Template HERE!

Eduardo Rolon
Moderator
alemanda wrote:
what kind of cleaning did you performed?
FYI,
Alemanda, the post you were referring to was removed because it was Spam so your comment is without context.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro 2.4 i9 32GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Barry Kelly
Moderator
One of my guys had a new machine that was going slow with version 20.
Info Box would take a couple of seconds to populate.
Turned out he had palettes dragged onto a second monitor.
I dragged them all back and docked them to the sides of the main program window and turned off those palettes he wasn't using.
Restarted the machine and it all seemed to be good again.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Link
Advocate
I’ve done all kinds of tests so far as this is affecting me and some of our clients. WE settings, video card settings, Windows 10 Visual Display settings. None of them made a difference.

The common theme seems to be nVidia so I suspect it may have to do with their drivers. It may be worth rolling them back pre-June 2017? Still waiting to hear back from GS on it.

Cheers,
Link.
Get your ARCHICAD 25 Template HERE!

KeesW
Booster
Link
If it is caused by NVidia, does it only apply to PC's? Apple uses a different video card, don't they?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
Link wrote:
The common theme seems to be nVidia so I suspect it may have to do with their drivers.
Make sure that Nvidia GeForce Experience program is disabled or deleted if that is installed and running.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

KeesW
Booster
Barry
How do I delete or disable the GeForce Experience program? Have I even got it?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
KeesW wrote:
Barry
How do I delete or disable the GeForce Experience program? Have I even got it?
Go into Control Panel > Programs & Features.
Look through the list for a program called 'Nvidia GeForce Experience'.
If it is there, right click on in and remove/uninstall.
If its not there then you don't have it.

You may have other Nvidia programs and drivers in that list - they should be fine.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
hey all,
I've been having similar issues lately, general 2d is really slow, deselecting is a second, 2 secs sometimes more. It has been getting really noticeable and annoying.

Have just updated to a new driver released 29th Jan.
Seems to have been a big improvement thus far.

check your graphics card drivers https://www.geforce.com/drivers

ps: disabling geoforce experience has had no effect (for me) before or after updating too, but that's not to say it won't work for others.

Anonymous
Not applicable
updated
since installing the latest library update for 21 (yesterday)
ac has reverted back to being slow and tedious....

alemanda
Beginner
...still struggling with AC21 slow down ...
I don't understand what causes so much slowness ...
The same file in the laptop works much better ...
AC 19 and AC21 latest hotfix
Win 10 Pro 64bit
Double XEON 14 CORES (tot 28 physical cores)
32GB RAM - SSD 256GB - Nvidia Quadro K620
Display DELL 25'' 2560x1440
www.almadw.it

Anonymous
Not applicable
I also have performance issues with Archicad 21. Its getting amazingly frustrating. Its even slow when i start a new project file.

The UI redraw is sluggish. If i change between element the properties tab takes 2-3 seconds to load. I get constant loading circle from windows. the viewport is also very slow.

And this is not only on windows. I experience the same thing on mac os.
I have absolutely no idea why this is happening. i have the latest updates for everything

a few months ago everything was running fine.

My hardware:
PC - win 10 pro, ryzen 1700, 32gb ram, gtx 1070, 500gb ssd
MAC - high sierra, fully decked out 15" MBP mid 2014 2.5 ghz i7, 16gb ram, gt 750m

Barry Kelly
Moderator
You have 2 different machines - PC and MAC.
Is the same thing happening on both?

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
You have 2 different machines - PC and MAC.
Is the same thing happening on both?

Barry.
yes.

Anonymous
Not applicable
Options > Work Environment > Advanced Redraw Options>Model Display in 2D Navi>Structural Contours Onlyours Only for quickly navigation !

ares997
Newcomer
In Work Environment > Company Standards and Schemes > Data Safety and Integrity > Save and Recovery options
Adjust the frequency of backups from Ultra Safe to something more reasonable like 5 or 20 minuet intervals.

Also in User Preferences Schemes > Model Rebuild Options there are some adjustments that can be made there that might enable better performance.
Archicad 23 (3003), Windows 10, AMD RYZEN 7 3900 (64 GB RAM)

Barry Kelly
Moderator
Also have a look at this post.

https://archicad-talk.graphisoft.com/viewtopic.php?f=13&t=59564

There are a couple of other similar ones I think if you do a bit of searching.

Try setting some exceptions in you virus scanning software.
This seems to have helped many people in speeding Archicad up.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!